<!DOCTYPE html>
<!--[if lt IE 7]> <html lang="en-US" class="no-js ie6"> <![endif]-->
<!--[if IE 7]>    <html lang="en-US" class="no-js ie7"> <![endif]-->
<!--[if IE 8]>    <html lang="en-US" class="no-js ie8"> <![endif]-->
<!--[if IE 9]>    <html lang="en-US" class="no-js ie9"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>
	<meta charset="UTF-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0">
	<title>
		GLOBAL GROCERIES | One of the few true butcher shops still left in Minneapolis has a lot of fans | Twin Cities Daily Planet	</title>
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://www.tcdailyplanet.net/xmlrpc.php" />
		<script>
			function whichHeader() {
				var screenWidth = document.documentElement.clientWidth,
				header_img;
				if (screenWidth <= 767) {
					header_img = 'https://www.tcdailyplanet.net/wp-content/uploads/2014/06/DP-logo-without-5702-336x661-336x66.png';
				} else if (screenWidth > 767 && screenWidth <= 979) {
					header_img = 'https://www.tcdailyplanet.net/wp-content/uploads/2014/06/DP-logo-without-5702-336x662-336x66.png';
				} else {
					header_img = 'https://www.tcdailyplanet.net/wp-content/uploads/2014/06/DP-logo-without-5702-336x663-336x66.png';
				}
				return header_img;
			}
			var banner_img_src = whichHeader();
		</script>
	<link rel='dns-prefetch' href='//cdn.rawgit.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; Feed" href="https://www.tcdailyplanet.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; Comments Feed" href="https://www.tcdailyplanet.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; GLOBAL GROCERIES | One of the few true butcher shops still left in Minneapolis has a lot of fans Comments Feed" href="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.tcdailyplanet.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slides-css'  href='https://www.tcdailyplanet.net/wp-content/themes/largo/lib/navis-slideshows/css/slides.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slick-css'  href='https://www.tcdailyplanet.net/wp-content/themes/largo/lib/navis-slideshows/vendor/slick/slick.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='evo_sr_styles-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/eventon-search/assets/styles.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='super-rss-reader-css-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/super-rss-reader/public/css/style.min.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='largo-stylesheet-css'  href='https://www.tcdailyplanet.net/?ver=4.8.3&#038;largo_custom_less_variable=1&#038;css_file=style.min.css&#038;timestamp=0' type='text/css' media='all' />
<link rel='stylesheet' id='largo-child-styles-css'  href='https://www.tcdailyplanet.net/wp-content/themes/tcdailyplanet-largo-child/style.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A400%2C400i%2C300&#038;ver=4.8.3' type='text/css' media='screen' />
<link rel='stylesheet' id='evcal_cal_default-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/css/eventon_styles.css?ver=2.4.10' type='text/css' media='all' />
<link rel='stylesheet' id='evo_font_icons-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/fonts/font-awesome.css?ver=2.4.10' type='text/css' media='all' />
<link rel='stylesheet' id='eventon_dynamic_styles-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/css/eventon_dynamic_styles.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='yarpp-thumbnails-yarpp-thumbnail-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/yet-another-related-posts-plugin/includes/styles_thumbnails.css.php?width=120&#038;height=120&#038;ver=4.4' type='text/css' media='all' />
<link rel='stylesheet' id='evo_fc_styles-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/eventon-full-cal/assets/fc_styles.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='homepage-slider-css'  href='https://www.tcdailyplanet.net/wp-content/themes/largo/homepages/assets/css/top-stories.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='argo-links-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/argo-links/css/argo-links.css?ver=1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/plugins/super-rss-reader/public/js/script.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://cdn.rawgit.com/vaakash/jquery-easy-ticker/92e6e76c/jquery.easy-ticker.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/modernizr.custom.js?ver=4.8.3'></script>
<link rel='https://api.w.org/' href='https://www.tcdailyplanet.net/wp-json/' />
<link rel='prev' title='Public health spending focuses on children, mentally ill' href='https://www.tcdailyplanet.net/public-health-spending-focuses-children-mentally-ill/' />
<link rel='next' title='Parents: Raise Your Children to be Artists and Entrepreneurs' href='https://www.tcdailyplanet.net/parents-raise-your-children-be-artists-and-entrepreneurs/' />
<link rel="canonical" href="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/" />
<link rel='shortlink' href='https://www.tcdailyplanet.net/?p=205784' />
<link rel="alternate" type="application/json+oembed" href="https://www.tcdailyplanet.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tcdailyplanet.net%2Fglobal-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.tcdailyplanet.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tcdailyplanet.net%2Fglobal-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans%2F&#038;format=xml" />
<link rel="stylesheet" href="https://www.tcdailyplanet.net/wp-content/plugins/multi-column-taxonomy-list/css/multi-column-taxonomy-link.css" type="text/css" />
		<meta name="twitter:card" content="summary">

		<meta name="twitter:site" content="@tcdailyplanet">
							<meta property="og:title" content="GLOBAL GROCERIES | One of the few true butcher shops still left in Minneapolis has a lot of fans" />
					<meta property="og:type" content="article" />
					<meta property="og:url" content="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/"/>
					<meta property="og:description" content="The Finer Meat Company, the tiny butcher shop near the corner of Nicollet and 38th, has been providing the best in meat to South Minneapolis since the depth of the Great Depression. First opened in 1932 at 36th and Bryant (now Gigi’s,) the shop moved to its current location and was then sold to Aaron [&hellip;]" />
					<meta name="description" content="The Finer Meat Company, the tiny butcher shop near the corner of Nicollet and 38th, has been providing the best in meat to South Minneapolis since the depth of the Great Depression. First opened in 1932 at 36th and Bryant (now Gigi’s,) the shop moved to its current location and was then sold to Aaron [&hellip;]" />
			<meta property="og:site_name" content="Twin Cities Daily Planet" /><meta property="og:image" content="https://www.tcdailyplanet.net/wp-content/uploads/files/15/02/the_finer_meat_company_has_been_in_the_same_family_since_1963_as_the_neighborhood_has_changed_around_them.jpg" /><link rel="shortcut icon" href="https://www.tcdailyplanet.net/wp-content/uploads/2014/06/tcdp_inside_favicon1.ico"/><meta name="news_keywords" content="Article, Business, Food and restaurants, Local"><meta name="original-source" content="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/" /><meta name="syndication-source" content="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/" />			<script>
			    var _gaq = _gaq || [];
							_gaq.push(['_setAccount', 'UA-1003974-1']);
				_gaq.push(['_trackPageview']);
										    _gaq.push(
					["largo._setAccount", "UA-17578670-4"],
					["largo._setCustomVar", 1, "SiteName", "Twin Cities Daily Planet"],
					["largo._setDomainName", "www.tcdailyplanet.net"],
					["largo._setAllowLinker", true],
					["largo._trackPageview"]
				);

			    (function() {
				    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
				    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
				    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
	

<!-- EventON Version -->
<meta name="generator" content="EventON 2.4.10" />

	<!-- Include google_services.js -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1000577/tcdp-leaderboard-728x90-wp', [728,90], "acm-ad-tag-tcdp-leaderboard-728x90-wp").addService(googletag.pubads());
googletag.defineSlot('/1000577/tcdp-sbmain-wp-01', [300,250], "acm-ad-tag-tcdp-sbmain-wp-01").addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>
</head>

<body class="post-template-default single single-post postid-205784 single-format-standard classic">

	<div id="top"></div>

	
		<div class="global-nav-bg">
		<div class="global-nav">
			<nav id="top-nav" class="span12">
				<span class="visuallyhidden">
					<a href="#main" title="Skip to content">Skip to content</a>
				</span>
				<ul id="menu-global-navigation" class="menu"><li id="menu-item-208085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208085"><a href="https://www.tcdailyplanet.net/advertise/">Advertise</a></li>
<li id="menu-item-208086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208086"><a href="https://www.tcdailyplanet.net/contact-us/">Contact us</a></li>
<li id="menu-item-208087" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208087"><a href="https://www.tcdailyplanet.net/subscribe-newsletters/">Subscribe to Newsletters</a></li>
</ul>				<div class="nav-right">
											<ul id="header-social" class="social-icons visible-desktop">
							<li><a href="https://www.tcdailyplanet.net/?feed=rss2" title="Link to RSS Feed"><i class="icon-rss"></i></a></li><li><a href="https://facebook.com/tcdailyplanet" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/tcdailyplanet" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li>						</ul>
					<div class="donate-btn"><a href="http://www.tcdailyplanet.net/donate"><i class="icon-heart"></i>Donate Now</a></div> 
					<div id="header-search">
						<form class="form-search" role="search" method="get" action="https://www.tcdailyplanet.net/">
							<div class="input-append">
								<input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" /><button type="submit" class="search-submit btn">Go</button>
							</div>
						</form>
					</div>

				</div>
			</nav>
		</div> <!-- /.global-nav -->
	</div> <!-- /.global-nav-bg -->

	<div id="page" class="hfeed clearfix">

		
		<!---<div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
-->

		
<header id="site-header" class="clearfix dp-header-test branding" itemscope itemtype="http://schema.org/Organization">
<div class="row-fluid clearfix">
		<div class="span4 dp-header-test hidden-phone"><h2 class="visuallyhidden"><a itemprop="url" href="https://www.tcdailyplanet.net/"><span itemprop="name">Twin Cities Daily Planet</span> - <span class="tagline" itemprop="description">Amplifying and connecting marginalized voices</span></a></h2><a itemprop="url" href="https://www.tcdailyplanet.net/"><img class="header_img" src="" alt="" /></a></div>
		<div class="span8 dp-header-test hidden-phone" ><div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
</div>
	</div>
	<div class="row-fluid clearfix">
		<div class="span12 dp-header-test visible-phone"><h2 class="visuallyhidden"><a itemprop="url" href="https://www.tcdailyplanet.net/"><span itemprop="name">Twin Cities Daily Planet</span> - <span class="tagline" itemprop="description">Amplifying and connecting marginalized voices</span></a></h2><a itemprop="url" href="https://www.tcdailyplanet.net/"><img class="header_img" src="" alt="" /></a></div>
	</div>
	<div class="row-fluid clearfix">
		<!--<div class="span12 dp-header-test visible-phone" ><div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
</div>-->
	</div>
	

			

		
</header>
<header class="print-header">
	<p><strong>Twin Cities Daily Planet</strong> (https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/)</p>
</header>


		<nav id="main-nav" class="navbar clearfix">
	<div class="navbar-inner">
		<div class="container">
			<!-- .btn-navbar is used as the toggle for collapsed navbar content -->
			<a class="btn btn-navbar toggle-nav-bar"  title="More">
				<div class="bars">
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
				</div>
			</a>

			<div class="nav-shelf">
				<ul class="nav">
					<li id="menu-item-208065" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-208065"><a href="https://www.tcdailyplanet.net/">Home</a></li>
<li id="menu-item-638045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-638045"><a href="https://www.tcdailyplanet.net/about-2/">About</a></li>
<li id="menu-item-208096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-208096"><a href="https://www.tcdailyplanet.net/category/news/">News + Features</a></li>
<li id="menu-item-307496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-307496"><a href="https://www.tcdailyplanet.net/category/arts/">Arts + Culture</a></li>
<li id="menu-item-208098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-208098"><a href="https://www.tcdailyplanet.net/category/community-voices/">Community Voices</a></li>
<li id="menu-item-379992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-379992"><a href="https://www.tcdailyplanet.net/category/blogs/">Blogs</a></li>
<li id="menu-item-208066" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-208066"><a href="#" class="dropdown-toggle">Partners <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li id="menu-item-208067" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208067"><a href="https://www.tcdailyplanet.net/partner_type/contributing-blogs/">Contributing Blogs</a></li>
	<li id="menu-item-208068" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208068"><a href="https://www.tcdailyplanet.net/partner_type/community-media/">Community Media</a></li>
	<li id="menu-item-208069" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208069"><a href="https://www.tcdailyplanet.net/partner_type/arts-media/">Arts Media</a></li>
	<li id="menu-item-208070" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208070"><a href="https://www.tcdailyplanet.net/partner_type/ethnic-media/">Ethnic Media</a></li>
	<li id="menu-item-208071" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208071"><a href="https://www.tcdailyplanet.net/partner_type/neighborhood-associations/">Neighborhood Associations</a></li>
</ul>
</li>
<li id="menu-item-675422" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-675422"><a href="https://www.tcdailyplanet.net/event-directory/">Events</a></li>
<li id="menu-item-675423" class="menu-item menu-item-type-taxonomy menu-item-object-event_type menu-item-675423"><a href="https://www.tcdailyplanet.net/event-type/classes/">Classes</a></li>
<li id="menu-item-617426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-617426"><a href="https://www.tcdailyplanet.net/work-with-us/">Work with Us</a></li>
				</ul>

				<ul class="nav visible-phone">
										<li class="menu-item-has-childen dropdown">
						<a href="javascript:void(0);" class="dropdown-toggle">Global Navigation <b class="caret"></b>
						</a>
						<ul id="menu-global-navigation-1" class="dropdown-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208085"><a href="https://www.tcdailyplanet.net/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208086"><a href="https://www.tcdailyplanet.net/contact-us/">Contact us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208087"><a href="https://www.tcdailyplanet.net/subscribe-newsletters/">Subscribe to Newsletters</a></li>
</ul>					</li>
									</ul>
			</div>
		</div>
	</div>
</nav>
<nav id="secondary-nav" class="clearfix">
	<div id="topics-bar" class="span12 hidden-phone">
		<ul id="menu-dont-miss" class="menu"><li class="menu-label"></li></ul>	</div>
</nav>


		
		
		<div id="main" class="row-fluid clearfix">

		
<div id="content" class="span8" role="main">

	
<article id="post-205784" class="hnews item post-205784 post type-post status-publish format-standard has-post-thumbnail hentry category-article category-business category-food-and-restaurants category-local" itemscope itemtype="http://schema.org/Article">

	
	<header>

 		<h1 class="entry-title" itemprop="headline">GLOBAL GROCERIES | One of the few true butcher shops still left in Minneapolis has a lot of fans</h1>
 		<h5 class="byline"><span class="by-author"><span class="by">By</span> <span class="author vcard" itemprop="author">Stephanie Fox (<a href="">Global Groceries</a>)</span></span><span class="sep"> | </span><time class="entry-date updated dtstamp pubdate" datetime="2015-02-02T16:02:19+00:00">February 2, 2015</time></h5>

 		<div class="post-social clearfix"><div class="left"><span class="twitter"><a href="http://twitter.com/share" class="twitter-share-button" data-url="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/" data-text="GLOBAL GROCERIES | One of the few true butcher shops still left in Minneapolis has a lot of fans" data-via="tcdailyplanet" data-via="" >Tweet</a></span><span class="facebook"><fb:like href="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/" send="false" layout="button_count" show_faces="false" action="like"></fb:like></span></div><div class="right"><span class="print"><a href="#" onclick="window.print()" title="Print this article" rel="nofollow"><i class="icon-print"></i> Print</a></span><span data-service="email" class="email custom-share-button icon-mail share-button"> Email</span></div></div>
 		<meta itemprop="description" content="The Finer Meat Company, the tiny butcher shop near the corner of Nicollet and 38th, has been providing the best in meat to South Minneapolis since the depth of the Great Depression. First opened in 1932 at 36th and Bryant (now Gigi’s,) the shop moved to its current location and was then sold to Aaron Knopik in 1963. It hasn’t changed very much since then.Many customers have been coming to Finer Meats for years, even before a very young Brian Knopik stood on a milk crate helping stock the shelves for the family business. “My grandfather bought it on Saturday and opened it again on Monday,” said Knopik, who now runs the place. Knopik works with his fiancé, Stacy Tollefson who met Knopik five years ago and signed on as a rookie butcher the same night.The shop’s customer demographic is mostly the same as it was 50 years ago – African-American soul food cooks from the local neighborhood. 

Related stories:
No related posts.

" />
<meta itemprop="datePublished" content="2015-02-02T16:02:19+00:00" />
<meta itemprop="dateModified" content="2015-02-02T16:11:41+00:00" />
<meta itemprop="image" content="https://www.tcdailyplanet.net/wp-content/uploads/files/15/02/the_finer_meat_company_has_been_in_the_same_family_since_1963_as_the_neighborhood_has_changed_around_them.jpg" />
	</header><!-- / entry header -->

			<div class="hero  is-image">
		<div class="dp-featured-image-container"><div class="dp-featured-image clearfix"><img width="1170" height="759" src="https://www.tcdailyplanet.net/wp-content/uploads/files/15/02/the_finer_meat_company_has_been_in_the_same_family_since_1963_as_the_neighborhood_has_changed_around_them.jpg" class="attachment-full size-full wp-post-image" alt="" />	</div>
	
	<div class="entry-content clearfix" itemprop="articleBody">
		<p><a href="http://www.finermeatco.com/index.html">The Finer Meat Company</a>, the tiny butcher shop near the corner of Nicollet and 38<sup>th</sup>, has been providing the best in meat to South Minneapolis since the depth of the Great Depression. First opened in 1932 at 36<sup>th</sup> and Bryant (now Gigi’s,) the shop moved to its current location and was then sold to Aaron Knopik in 1963. It hasn’t changed very much since then.</p>
<p>Many customers have been coming to Finer Meats for years, even before a very young Brian Knopik stood on a milk crate helping stock the shelves for the family business. “My grandfather bought it on Saturday and opened it again on Monday,” said Knopik, who now runs the place. Knopik works with his fiancé, Stacy Tollefson who met Knopik five years ago and signed on as a rookie butcher the same night.</p>
<p>The shop’s customer demographic is mostly the same as it was 50 years ago – African-American soul food cooks from the local neighborhood. They still come to buy fixings and exchange recipes. But recently, a new customer base is discovering Finer Meats.</p>
<p>Last year, the store received its first upgrade in years. There’s a new logo on the door and an up-to-the-minute look to the outside. The curb appeal helps to attract the hip cats from Five Watt coffee next door and the trendy restaurants sharing the same block. (Restaurant Nighthawks will soon open where the fondly remembered <em>Shorty &amp; Wags Original Chicken Wings</em> used to be.)</p>
<p>Walk in, though and you’ll find the place decidedly old school. The floor is linoleum and the fluorescent lights are industrial. The tape machine for wrapping the meat in white butcher paper is from 1932, from the old location. But, that just speaks to the store’s authenticity. This is a non-apologetic butcher shop.</p>
<p>Unlike most supermarket butcher shops, you can order meat cut the way you want. Choose the thickness of your steak, ask one of the butchers to cut up a <a href="http://www.realcajunrecipes.com/recipe/duck-etoufee-stew/">duck for duck etoufee</a>, or bring in your own fish for a stint in the smoker. “Most places get their meat pre-cut, in boxes. They don’t have to equipment to cut meat. We can cut to order,” Knopik said, as he put turkey through the store’s the large electric saw.</p>
<p>Knopik recently invested in an all-digital scale and the smokehouse in the back got an upgrade four years ago, after a fire. “It happened on my birthday and we were home celebrating,” said Tollefson. “By the time we got back here, the fire fighters had it mostly out, but the back room had already collapsed. We spent $50,000 on a new smoke house. It’s all computerized. You can control it from your cell phone.”</p>
<p>Some things have changed. “When we opened in 1963, you didn’t have to lock your doors,” Knopik said. “Then in the ‘90s, you’d hear gunshots.”</p>
<p>“The hipsters are buying houses in the neighborhood and coming in to shop. They buy some of the same things as our mainstay customers, but they go on the Internet and find new recipes. They’re looking for hickory smoked pork belly or they’re part of the new bacon scene. They’re looking for things that most grocery stores don’t carry. They come here and buy our beef sticks to eat as they drink coffee at Five Watt next door. ” And, he said, the old customers are still faithful.</p>
<p>Curtis Lee, who lives in Southwest Minneapolis, is one of those old customers. He came to buy some of the smoked chicken, smoked pork and some of the store’s cut-to-order oxtails. “I boil the oxtails with onions until they’re fall off the bone,” he said.</p>
<p>Knopik make a lot of what he sells from scratch, many recipes handed down from his grandfather. He makes breakfast sausages, your choice of pork or beef and Finer Meat’s own recipe hot dogs, Polish and in the summer, brats. They sell a variety of jerky flavors and fresh meat and poultry as well. “I’ve added hot jerky,” said Knopik. “My grandfather didn’t like hot.”</p>
<p>In-house smoked meats include turkey wings, legs&nbsp;and tails, pork tails, feet, hocks and chops and beef ribs, all great for cooking beans and greens.</p>
<p>They make their own hams and six kinds of bacon; regular, skin-on, butt bacon, peppered butt bacon, beef bacon and the best lamb bacon in the Twin Cities. That’s right – fatty, smoky lamb bacon.</p>
<p>The lamb bacon was inspired by Sami Wadi, chef at Saffron, who told Brian’s father, “You have to come up with a lamb bacon. If you can’t do it, no one can.”</p>
<p>You can get fish – catfish, buffalo, perch, tilapia and walleye. There’s lamb at a reasonable price and thick cut lamb steaks. And they’ve just begun to carry organic cheese for their hipster customers.</p>
<p>The store is doing well, selling up to 3,500 lb. of meat, poultry and fish every week. Every Tuesday, the staff puts together an order for cold cuts, enough for 500 sandwiches for the Basilica of St. Mary’s sandwich program, free to all who are hungry.</p>
<p>The Finer Meat Company is located at 3747 Nicollet Ave. S. in Minneapolis. They’re open until 6:00 pm and are closed Sunday and Monday.</p>

			<div id="slides-205784-cff4c6be848ab089a683198c071743e9" class="navis-slideshow"><div id="205784-cff4c6be848ab089a683198c071743e9-slide1"><img data-lazy="https://www.tcdailyplanet.net/wp-content/uploads/files/slideshows/brian_and_stacy_1.jpg" /><h6 class="permalink"><a href="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/#205784-cff4c6be848ab089a683198c071743e9/1" class="slide-permalink"><i class="icon-link"></i> permalink</a></h6><p class="wp-caption-text">Brian and Stacy, owners (Credit: Stephanie Fox)</p></div><div id="205784-cff4c6be848ab089a683198c071743e9-slide2"><img data-lazy="https://www.tcdailyplanet.net/wp-content/uploads/files/slideshows/a_large_variety_of_smoked_meats_is_available_for_making_southern_style_cooking.jpg" /><h6 class="permalink"><a href="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/#205784-cff4c6be848ab089a683198c071743e9/2" class="slide-permalink"><i class="icon-link"></i> permalink</a></h6><p class="wp-caption-text">A large variety of smoked meats is available for making southern style cooking (Credit: Stephanie Fox)</p></div><div id="205784-cff4c6be848ab089a683198c071743e9-slide3"><img data-lazy="https://www.tcdailyplanet.net/wp-content/uploads/files/slideshows/knopik_cuts_turkey_legs_to_order.jpg" /><h6 class="permalink"><a href="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/#205784-cff4c6be848ab089a683198c071743e9/3" class="slide-permalink"><i class="icon-link"></i> permalink</a></h6><p class="wp-caption-text">Knopik cuts turkey legs to order (Credit: Stephanie Fox)</p></div><div id="205784-cff4c6be848ab089a683198c071743e9-slide4"><img data-lazy="https://www.tcdailyplanet.net/wp-content/uploads/files/slideshows/pigs_feet.jpg" /><h6 class="permalink"><a href="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/#205784-cff4c6be848ab089a683198c071743e9/4" class="slide-permalink"><i class="icon-link"></i> permalink</a></h6><p class="wp-caption-text">Pigs feet (Credit: Stephanie Fox)</p></div><div id="205784-cff4c6be848ab089a683198c071743e9-slide5"><img data-lazy="https://www.tcdailyplanet.net/wp-content/uploads/files/slideshows/steaks_cut_to_order.jpg" /><h6 class="permalink"><a href="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/#205784-cff4c6be848ab089a683198c071743e9/5" class="slide-permalink"><i class="icon-link"></i> permalink</a></h6><p class="wp-caption-text">Steaks cut to order (Credit: Stephanie Fox)</p></div><div id="205784-cff4c6be848ab089a683198c071743e9-slide6"><img data-lazy="https://www.tcdailyplanet.net/wp-content/uploads/files/slideshows/the_finer_meat_company_has_been_in_the_same_family_since_1963_as_the_neighborhood_has_changed_around_them.jpg" /><h6 class="permalink"><a href="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/#205784-cff4c6be848ab089a683198c071743e9/6" class="slide-permalink"><i class="icon-link"></i> permalink</a></h6><p class="wp-caption-text">The Finer Meat Company has been in the same family since 1963 as the neighborhood has changed around them(Credit: Stephanie Fox)</p></div></div>
<div class='yarpp-related yarpp-related-none'>
<h3>Related stories:</h3>
<p>No related posts.</p>
</div>
	</div><!-- .entry-content -->

	
	<footer class="post-meta bottom-meta">

    
	</footer><!-- /.post-meta -->

	
</article><!-- #post-205784 -->
	<div id="comments" class="clearfix">
	
	
			<h2 id="comments-title">
			One thought on &ldquo;<span>GLOBAL GROCERIES | One of the few true butcher shops still left in Minneapolis has a lot of fans</span>&rdquo;		</h2>

		
		<ol class="commentlist">
					<li class="comment even thread-even depth-1" id="li-comment-595092">
			<article id="comment-595092" class="comment">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/077362d3cf4488c21d7fe681399fa3e2?s=68&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/077362d3cf4488c21d7fe681399fa3e2?s=136&amp;d=mm&amp;r=g 2x' class='avatar avatar-68 photo' height='68' width='68' /><span class="fn">Tina Hammond -Johnson</span> on <a href="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/#comment-595092"><time pubdate datetime="2017-11-15T19:24:47+00:00">November 15, 2017 at 7:24 pm</time></a> <span class="says">said:</span>
											</div><!-- .comment-author .vcard -->

					
				</footer>

				<div class="comment-content"><p>I will be in town for the holidays,visiting from New York ,and would like to make my family oxtails. Do you still sell them? If so, great! We’ll be there to purchase some.</p>
</div>

				<div class="reply">
					<a rel='nofollow' class='comment-reply-link' href='https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/?replytocom=595092#respond' onclick='return addComment.moveForm( "comment-595092", "595092", "respond", "205784" )' aria-label='Reply to Tina Hammond -Johnson'>Reply <span>&darr;</span></a>				</div><!-- .reply -->
			</article><!-- #comment-## -->

		</li><!-- #comment-## -->
		</ol>

		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.tcdailyplanet.net/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='205784' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="45037c349c" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="98"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->
</div>


<aside id="sidebar" class="span4">
		<div class="widget-area " role="complementary">
		<aside id="acm_ad_zones-10" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-sbmain-wp-01' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-sbmain-wp-01'); });
</script>
		</div>
		</aside><aside id="text-6" class="widget widget-2 even default widget_text clearfix"><h3 class="widgettitle">Submit an event</h3>			<div class="textwidget">Please complete the  <a href="http://www.tcdailyplanet.net/event-submission/">form here</a> to submit an event to our calendar.</div>
		</aside><aside id="text-4" class="widget widget-3 odd default widget_text clearfix"><h3 class="widgettitle">Tweets from TC Daily Planet</h3>			<div class="textwidget"><a class="twitter-timeline" href="https://twitter.com/tcdailyplanet" data-widget-id="548900467502096384">Tweets by @tcdailyplanet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		</aside><aside id="largo-featured-widget-5" class="widget widget-4 even default largo-featured clearfix"><h3 class="widgettitle">Today&#8217;s top stories</h3>			<div class="post-lead clearfix">
			<img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Eric-Kaler-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Eric-Kaler-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Eric-Kaler-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Eric-Kaler-32x32.jpg 32w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Eric-Kaler-50x50.jpg 50w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Eric-Kaler-64x64.jpg 64w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Eric-Kaler-96x96.jpg 96w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Eric-Kaler-128x128.jpg 128w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Eric-Kaler-120x120.jpg 120w" sizes="(max-width: 60px) 100vw, 60px" />			<h5><a href="https://www.tcdailyplanet.net/best-of-neighborhood-news-1116-umn-administrators-seek-to-prevent-sexual-assault-through-culture-change/">Best of Neighborhood News 11/16: UMN administrators seek to prevent sexual assault through culture change</a></h5>
						<p>University of Minnesota administrators have created a plan to prevent sexual misconduct on campus, which will strive to bring about a cultural attitude shift toward sexual assault. Much of the plan focuses on training and awareness of sexual assault, which will become mandatory for faculty and staff, as reported by the Minnesota Daily. </p>				</div> <!-- /.post-lead -->
					<div class="post-lead clearfix">
			<img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2017/11/kids-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2017/11/kids-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/kids-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/kids-32x32.jpg 32w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/kids-50x50.jpg 50w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/kids-64x64.jpg 64w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/kids-96x96.jpg 96w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/kids-128x128.jpg 128w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/kids-120x120.jpg 120w" sizes="(max-width: 60px) 100vw, 60px" />			<h5><a href="https://www.tcdailyplanet.net/community-voices-a-call-for-regeneration-over-reparations-where-black-potential-has-been-stifled/">Community Voices: A call for ‘regeneration’ over reparations where Black potential has been stifled</a></h5>
						<p>If you seek to learn about reparations specifically for Black people living in what we call the United States of America, you will see a contentious debate. </p>				</div> <!-- /.post-lead -->
					<div class="post-lead clearfix">
			<img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Peggy-Flanagan-1-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Peggy-Flanagan-1-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Peggy-Flanagan-1-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Peggy-Flanagan-1-32x32.jpg 32w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Peggy-Flanagan-1-50x50.jpg 50w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Peggy-Flanagan-1-64x64.jpg 64w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Peggy-Flanagan-1-96x96.jpg 96w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Peggy-Flanagan-1-128x128.jpg 128w, https://www.tcdailyplanet.net/wp-content/uploads/2017/11/Peggy-Flanagan-1-120x120.jpg 120w" sizes="(max-width: 60px) 100vw, 60px" />			<h5><a href="https://www.tcdailyplanet.net/peggy-flanagan-could-become-the-highest-ranking-native-woman-to-hold-public-office/">Peggy Flanagan could become the highest ranking Native woman to hold public office</a></h5>
						<p>“It matters that people see themselves reflected in the leaders that represent them,” said state Rep. Peggy Flanagan (DFL-St. </p>				</div> <!-- /.post-lead -->
				
		</aside><aside id="largo-explore-related-widget-2" class="widget widget-5 odd default largo-explore-related clearfix">
			<div id="related-posts" class="idTabs row-fluid clearfix">
				<ul id="related-post-nav" class="span4">
					<li><h5>In case you missed it</h5></li>
					<li><a href="#rp0">Article</a></li><li><a href="#rp1">Business</a></li><li><a href="#rp2">Food and restaurants</a></li><li><a href="#rp3">Local</a></li>				</ul>

				<div class="related-items span8">
											<div id="rp0">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="https://www.tcdailyplanet.net/so-long-open-streets-its-been-fun/" title="Read So long Open Streets. It&#039;s been fun!">So long Open Streets. It&#039;s been fun!</a></h3><a href="https://www.tcdailyplanet.net/so-long-open-streets-its-been-fun/"/><img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-32x32.jpg 32w, https://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-64x64.jpg 64w, https://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-96x96.jpg 96w, https://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-128x128.jpg 128w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>Lowry Avenue in North Minneapolis hosted the season's last Open Streets event. Photographer Mark Peterson was there to catch all the action. </p>								</li>
								<li><a href="https://www.tcdailyplanet.net/viva-mexico-minneapolis-celebrates-mexican-independence-day/" title="Article">Viva Mexico! Minneapolis celebrates Mexican Independence Day</a></li><li><a href="https://www.tcdailyplanet.net/sugarush-donuts-light-rail-green-line/" title="Article">A doughnut shop owner looks to the future on (or near) the light rail</a></li>							</ul>

							<p><a href="https://www.tcdailyplanet.net/category/article/" title="Article" target="_blank"><strong>View all Article Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
											<div id="rp1">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="https://www.tcdailyplanet.net/38th-street-and-plans-for-renewal/" title="Read 38th Street and plans for renewal">38th Street and plans for renewal</a></h3><a href="https://www.tcdailyplanet.net/38th-street-and-plans-for-renewal/"/><img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2015/05/Sabathani2-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2015/05/Sabathani2-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2015/05/Sabathani2-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2015/05/Sabathani2-50x50.jpg 50w, https://www.tcdailyplanet.net/wp-content/uploads/2015/05/Sabathani2-32x32.jpg 32w, https://www.tcdailyplanet.net/wp-content/uploads/2015/05/Sabathani2-64x64.jpg 64w, https://www.tcdailyplanet.net/wp-content/uploads/2015/05/Sabathani2-96x96.jpg 96w, https://www.tcdailyplanet.net/wp-content/uploads/2015/05/Sabathani2-128x128.jpg 128w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>The opening of the Seward food co-op on 38th and 4th Avenue is probably the biggest non-governmental development to hit 38th Street in at least 50 years.  But it has brought into sharp relief the under-utilized and under-appreciated business districts along the rest of 38th Street.

Council Member Elizabeth Glidden has been tirelessly organizing community meetings to encourage neighbors to remember the old neighborhood and imagine new possibilities for the street.  The first three meetings had visits by former residents who have left the ‘hood and become famous, like Judge Lajune Lange and Gary Cunningham.

Besides being married to the mayor, Gary Cunningham is the executive director of the Metropolitan Economic Development Association and a member of the Metropolitan Council.  A picture of the Bryant-Central co-op hangs on his office wall.  He says it is one of his sources of inspiration.  </p>								</li>
								<li><a href="https://www.tcdailyplanet.net/seward-co-ops-friendship-store-and-community-benefits/" title="Business">Seward Co-op’s Friendship Store and “Community Benefits”</a></li><li><a href="https://www.tcdailyplanet.net/dinky-gets-closer-new-status/" title="Business">Dinky gets closer to new status</a></li>							</ul>

							<p><a href="https://www.tcdailyplanet.net/category/work-economy/business/" title="Business" target="_blank"><strong>View all Business Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
											<div id="rp2">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="https://www.tcdailyplanet.net/north-minneapolis-takes-back-food-systems-land-through-urban-agriculture/" title="Read North Minneapolis takes back food systems, land through urban agriculture">North Minneapolis takes back food systems, land through urban agriculture</a></h3><a href="https://www.tcdailyplanet.net/north-minneapolis-takes-back-food-systems-land-through-urban-agriculture/"/><img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2016/07/IMG_6575-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="Project sweetie pie north minneapolis" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2016/07/IMG_6575-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2016/07/IMG_6575-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2016/07/IMG_6575-32x32.jpg 32w, https://www.tcdailyplanet.net/wp-content/uploads/2016/07/IMG_6575-50x50.jpg 50w, https://www.tcdailyplanet.net/wp-content/uploads/2016/07/IMG_6575-64x64.jpg 64w, https://www.tcdailyplanet.net/wp-content/uploads/2016/07/IMG_6575-96x96.jpg 96w, https://www.tcdailyplanet.net/wp-content/uploads/2016/07/IMG_6575-128x128.jpg 128w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>Transforming the community and its residents is the main goal of Northside food system organizers, who are using food as a tool to aid in that transformation. </p>								</li>
								<li><a href="https://www.tcdailyplanet.net/ha-tien-market-green-line/" title="Food and restaurants">Ha Tien Market still finds home along the Green Line, despite problems</a></li><li><a href="https://www.tcdailyplanet.net/good-grocer-food-marketplace-mpls/" title="Food and restaurants">Everyone is welcome at Good Grocer, a new kind of food marketplace</a></li>							</ul>

							<p><a href="https://www.tcdailyplanet.net/category/food-and-restaurants/" title="Food and restaurants" target="_blank"><strong>View all Food and restaurants Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
											<div id="rp3">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="https://www.tcdailyplanet.net/ha-tien-market-green-line/" title="Read Ha Tien Market still finds home along the Green Line, despite problems">Ha Tien Market still finds home along the Green Line, despite problems</a></h3><a href="https://www.tcdailyplanet.net/ha-tien-market-green-line/"/><img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2015/11/MG_3912-1-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="Ha Tien Market" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2015/11/MG_3912-1-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2015/11/MG_3912-1-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2015/11/MG_3912-1-32x32.jpg 32w, https://www.tcdailyplanet.net/wp-content/uploads/2015/11/MG_3912-1-64x64.jpg 64w, https://www.tcdailyplanet.net/wp-content/uploads/2015/11/MG_3912-1-96x96.jpg 96w, https://www.tcdailyplanet.net/wp-content/uploads/2015/11/MG_3912-1-128x128.jpg 128w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>On a rainy, cool day Ha Tien is a warm and welcoming site.</p>								</li>
								<li><a href="https://www.tcdailyplanet.net/good-grocer-food-marketplace-mpls/" title="Local">Everyone is welcome at Good Grocer, a new kind of food marketplace</a></li><li><a href="https://www.tcdailyplanet.net/the-dubliner-pub-a-neighborhood-bar-at-heart/" title="Local">The Dubliner Pub: A neighborhood bar at heart</a></li>							</ul>

							<p><a href="https://www.tcdailyplanet.net/category/local/" title="Local" target="_blank"><strong>View all Local Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
									</div> <!-- /.items -->
			</div> <!-- /#related-posts -->
		</aside>	</div>
	</aside>

	</div> <!-- #main -->

</div><!-- #page -->


<div class="footer-bg clearfix">
	<footer id="site-footer">

		<div id="supplementary" class="row-fluid">
	
	<div class="span4 widget-area" role="complementary">
		<ul id="menu-footer-navigation" class="menu"><li class="menu-label"></li><li id="menu-item-307252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-307252"><a href="https://www.tcdailyplanet.net/67262-2/">20/20 Tips for Community Journalists</a></li>
</ul>	</div>

	<div class="span4 widget-area" role="complementary">
		<aside id="text-7" class="widget widget-1 odd default widget_text clearfix">			<div class="textwidget"></div>
		</aside>	</div>

	<div class="span4 widget-area" role="complementary">
		<div class="widget widget_search"><h2 class="widgettitle">Search This Site</h2>
	<form class="form-search" role="search" method="get" action="https://www.tcdailyplanet.net/">
		<div>
			<input type="text" placeholder="Search" class="searchbox search-query" value="" name="s" />
			<input type="submit" value="Go" name="search submit" class="search-submit btn">
		</div>
	</form>

</div><div class="widget widget_archive"><h2 class="widgettitle">Browse Archives</h2>		<label class="screen-reader-text" for="archives-dropdown--1">Browse Archives</label>
		<select id="archives-dropdown--1" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://www.tcdailyplanet.net/2017/11/'> November 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/10/'> October 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/09/'> September 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/08/'> August 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/07/'> July 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/06/'> June 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/05/'> May 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/04/'> April 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/03/'> March 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/02/'> February 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/01/'> January 2017 </option>
	<option value='https://www.tcdailyplanet.net/2016/12/'> December 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/11/'> November 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/10/'> October 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/09/'> September 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/08/'> August 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/07/'> July 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/06/'> June 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/05/'> May 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/04/'> April 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/03/'> March 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/02/'> February 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/01/'> January 2016 </option>
	<option value='https://www.tcdailyplanet.net/2015/12/'> December 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/11/'> November 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/10/'> October 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/09/'> September 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/08/'> August 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/07/'> July 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/06/'> June 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/05/'> May 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/04/'> April 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/03/'> March 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/02/'> February 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/01/'> January 2015 </option>
	<option value='https://www.tcdailyplanet.net/2014/12/'> December 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/11/'> November 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/10/'> October 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/09/'> September 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/08/'> August 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/07/'> July 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/06/'> June 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/05/'> May 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/04/'> April 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/03/'> March 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/02/'> February 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/01/'> January 2014 </option>
	<option value='https://www.tcdailyplanet.net/2013/12/'> December 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/11/'> November 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/10/'> October 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/09/'> September 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/08/'> August 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/07/'> July 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/06/'> June 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/05/'> May 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/04/'> April 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/03/'> March 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/02/'> February 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/01/'> January 2013 </option>
	<option value='https://www.tcdailyplanet.net/2012/12/'> December 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/11/'> November 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/10/'> October 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/09/'> September 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/08/'> August 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/07/'> July 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/06/'> June 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/05/'> May 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/04/'> April 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/03/'> March 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/02/'> February 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/01/'> January 2012 </option>
	<option value='https://www.tcdailyplanet.net/2011/12/'> December 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/11/'> November 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/10/'> October 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/09/'> September 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/08/'> August 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/07/'> July 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/06/'> June 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/05/'> May 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/04/'> April 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/03/'> March 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/02/'> February 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/01/'> January 2011 </option>
	<option value='https://www.tcdailyplanet.net/2010/12/'> December 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/11/'> November 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/10/'> October 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/09/'> September 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/08/'> August 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/07/'> July 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/06/'> June 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/05/'> May 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/04/'> April 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/03/'> March 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/02/'> February 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/01/'> January 2010 </option>
	<option value='https://www.tcdailyplanet.net/2009/12/'> December 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/11/'> November 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/10/'> October 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/09/'> September 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/08/'> August 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/07/'> July 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/06/'> June 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/05/'> May 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/04/'> April 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/03/'> March 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/02/'> February 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/01/'> January 2009 </option>
	<option value='https://www.tcdailyplanet.net/2008/12/'> December 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/11/'> November 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/10/'> October 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/09/'> September 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/08/'> August 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/07/'> July 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/06/'> June 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/05/'> May 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/04/'> April 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/03/'> March 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/02/'> February 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/01/'> January 2008 </option>
	<option value='https://www.tcdailyplanet.net/2007/12/'> December 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/11/'> November 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/10/'> October 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/09/'> September 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/08/'> August 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/07/'> July 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/06/'> June 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/05/'> May 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/04/'> April 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/03/'> March 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/02/'> February 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/01/'> January 2007 </option>
	<option value='https://www.tcdailyplanet.net/2006/12/'> December 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/11/'> November 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/10/'> October 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/09/'> September 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/08/'> August 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/07/'> July 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/06/'> June 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/05/'> May 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/04/'> April 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/03/'> March 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/02/'> February 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/01/'> January 2006 </option>
	<option value='https://www.tcdailyplanet.net/2005/12/'> December 2005 </option>
	<option value='https://www.tcdailyplanet.net/2005/11/'> November 2005 </option>
	<option value='https://www.tcdailyplanet.net/2005/10/'> October 2005 </option>
	<option value='https://www.tcdailyplanet.net/2005/09/'> September 2005 </option>
	<option value='https://www.tcdailyplanet.net/2000/10/'> October 2000 </option>

		</select>
		</div>	</div>

	</div>
<div id="boilerplate">
	<div class="row-fluid clearfix">
		<div class="span9">
			<ul id="footer-social" class="social-icons">
				<li><a href="https://www.tcdailyplanet.net/?feed=rss2" title="Link to RSS Feed"><i class="icon-rss"></i></a></li><li><a href="https://facebook.com/tcdailyplanet" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/tcdailyplanet" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li>			</ul>
		</div>

			</div>

	<div class="row-fluid clearfix">
		<div class="span9">
			<div class="footer-bottom clearfix">

				<!-- If you enjoy this theme and use it on a production site we would appreciate it if you would leave the credit in place. Thanks :) -->
				<p class="footer-credit">&copy; Copyright 2017, Twin Cities Enterprise</p>
				<p class="footer-credit">This site built with <a href="http://largoproject.org">Project Largo</a> from <a href="http://inn.org">INN</a> and proudly powered by <a href="http://wordpress.org" rel="nofollow">WordPress</a>.</p>
			</div>
		</div>
		<div class="span3">
					</div>
	</div>

	<div class="row-fluid clearfix">
		<div class="span12">
			<p class="back-to-top"><a href="#top">Back to top &uarr;</a></p>
					</div>
	</div>
</div>

	</footer>
</div>

<div class="sticky-footer-holder">
	<div class="sticky-footer-container social-icons">

		
						<div class="comments">
			<a href="https://www.tcdailyplanet.net/global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans/#comments"><h4>Comment</h4> <i class="icon-comment"></i></a>
		</div>
		
		<div class="dismiss">
			<a href="#">
			<i class="icon-cancel"></i>
			</a>
		</div>

						<div class="follow">
			<h4>Follow</h4>

			<span class="post-category-link"><a href="https://www.tcdailyplanet.net/category/article/" title="Read Posts in the Article category"><i class="icon-white icon-tag"></i>Article</a></span>
																<div class="follow-author">
					<a href="https://www.tcdailyplanet.net/author/stephanie-fox/feed/stephanie-fox/" class="icon-rss"></a>
										<a href="https://www.tcdailyplanet.net/author/stephanie-fox/">Stephanie Fox</a>
					</div>
							
		</div>

	</div>
</div>
		<script type="text/javascript">
		/*<![CDATA[*/
		var gmapstyles = 'default';
		/* ]]> */
		</script>		
				<script type="text/javascript">
			var LMP = {"ajax_url":"https:\/\/www.tcdailyplanet.net\/wp-admin\/admin-ajax.php","paged":0,"query":{"post__not_in":null,"page":"","name":"global-groceries-one-few-true-butcher-shops-still-left-minneapolis-has-lot-fans"},"is_home":false,"is_series_landing":false};
		</script>
	

		
		<!--Facebook-->
		<div id="fb-root"></div>
		<script>(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script>

		
		
		<!--Twitter-->
		<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

		
	<div class='evo_lightboxes'>					<div class='evo_lightbox eventcard eventon_events_list' id=''>
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose '>X</a>
									<div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'></div>
								</div>
							</div>							
						</div>
					</div>
					</div><link rel='stylesheet' id='yarppRelatedCss-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.8.3' type='text/css' media='all' />
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/comment-reply.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/www/wp-content/themes/tcdailyplanet-largo-child/js/your_theme.js?ver=0.1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/load-more-posts.js'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/largoCore.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/largoPlugins.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/jquery.idTabs.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/wp-embed.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/lib/navis-slideshows/vendor/slick/slick.min.js?ver=3.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/lib/navis-slideshows/js/navis-slideshows.js?ver=0.1'></script>
<script async="async" type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/plugins/akismet/_inc/form.js?ver=4.0.1'></script>

</body>
</html>
