<!DOCTYPE html>
<!--[if lt IE 7]> <html lang="en-US" class="no-js ie6"> <![endif]-->
<!--[if IE 7]>    <html lang="en-US" class="no-js ie7"> <![endif]-->
<!--[if IE 8]>    <html lang="en-US" class="no-js ie8"> <![endif]-->
<!--[if IE 9]>    <html lang="en-US" class="no-js ie9"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>
	<meta charset="UTF-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0">
	<title>
		Best of Neighborhoods News 06/05/2019: Landlords push back on Minneapolis proposal to limit tenant screenings | Twin Cities Daily Planet	</title>
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://www.tcdailyplanet.net/xmlrpc.php" />
		<script>
			function whichHeader() {
				var screenWidth = document.documentElement.clientWidth,
				header_img;
				if (screenWidth <= 767) {
					header_img = 'https://www.tcdailyplanet.net/wp-content/uploads/2014/06/DP-logo-without-5702-336x661-336x66.png';
				} else if (screenWidth > 767 && screenWidth <= 979) {
					header_img = 'https://www.tcdailyplanet.net/wp-content/uploads/2014/06/DP-logo-without-5702-336x662-336x66.png';
				} else {
					header_img = 'https://www.tcdailyplanet.net/wp-content/uploads/2014/06/DP-logo-without-5702-336x663-336x66.png';
				}
				return header_img;
			}
			var banner_img_src = whichHeader();
		</script>
	<link rel='dns-prefetch' href='//cdn.rawgit.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; Feed" href="https://www.tcdailyplanet.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; Comments Feed" href="https://www.tcdailyplanet.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; Best of Neighborhoods News 06/05/2019: Landlords push back on Minneapolis proposal to limit tenant screenings Comments Feed" href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.tcdailyplanet.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slides-css'  href='https://www.tcdailyplanet.net/wp-content/themes/largo/lib/navis-slideshows/css/slides.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slick-css'  href='https://www.tcdailyplanet.net/wp-content/themes/largo/lib/navis-slideshows/vendor/slick/slick.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.tcdailyplanet.net/wp-includes/css/dist/block-library/style.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='super-rss-reader-css-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/super-rss-reader/public/css/style.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='largo-stylesheet-css'  href='https://www.tcdailyplanet.net/?ver=5.2.1&#038;largo_custom_less_variable=1&#038;css_file=style.min.css&#038;timestamp=0' type='text/css' media='all' />
<link rel='stylesheet' id='largo-child-styles-css'  href='https://www.tcdailyplanet.net/wp-content/themes/tcdailyplanet-largo-child/style.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A700%2C400%2C400i%7CRoboto%3A700%2C400&#038;ver=5.2.1' type='text/css' media='screen' />
<link rel='stylesheet' id='evcal_cal_default-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/css/eventon_styles.css?ver=2.6.17' type='text/css' media='all' />
<link rel='stylesheet' id='evo_font_icons-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/fonts/font-awesome.css?ver=2.6.17' type='text/css' media='all' />
<link rel='stylesheet' id='eventon_dynamic_styles-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/css/eventon_dynamic_styles.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='yarpp-thumbnails-yarpp-thumbnail-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/yet-another-related-posts-plugin/includes/styles_thumbnails.css.php?width=120&#038;height=120&#038;ver=4.4' type='text/css' media='all' />
<link rel='stylesheet' id='evo_fc_styles-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/eventon-full-cal/assets/fc_styles.css?ver=1.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='homepage-slider-css'  href='https://www.tcdailyplanet.net/wp-content/themes/largo/homepages/assets/css/top-stories.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='argo-links-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/argo-links/css/argo-links.css?ver=1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/plugins/super-rss-reader/public/js/script.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://cdn.rawgit.com/vaakash/jquery-easy-ticker/92e6e76c/jquery.easy-ticker.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/modernizr.custom.js?ver=5.2.1'></script>
<link rel='https://api.w.org/' href='https://www.tcdailyplanet.net/wp-json/' />
<link rel='prev' title='Best of Neighborhoods News 05/29/2019: Rep. Ilhan Omar introduces bill to ease path for mobile home residents to buy their parks' href='https://www.tcdailyplanet.net/best-of-neighborhoods-news-05-29-2019-rep-ilhan-omar-introduces-bill-to-ease-path-for-mobile-home-residents-to-buy-their-parks/' />
<link rel="canonical" href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/" />
<link rel='shortlink' href='https://www.tcdailyplanet.net/?p=2293557' />
<link rel="alternate" type="application/json+oembed" href="https://www.tcdailyplanet.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tcdailyplanet.net%2Fbest-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.tcdailyplanet.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tcdailyplanet.net%2Fbest-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings%2F&#038;format=xml" />
<link rel="stylesheet" href="https://www.tcdailyplanet.net/wp-content/plugins/multi-column-taxonomy-list/css/multi-column-taxonomy-link.css" type="text/css" />
		<meta name="twitter:card" content="summary">

		<meta name="twitter:site" content="@tcdailyplanet">
							<meta property="og:title" content="Best of Neighborhoods News 06/05/2019: Landlords push back on Minneapolis proposal to limit tenant screenings" />
					<meta property="og:type" content="article" />
					<meta property="og:url" content="https://www.tcdailyplanet.net/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/"/>
					<meta property="og:description" content="Landlords push back on Minneapolis proposal to limit tenant screeningsA proposed ordinance by the Minneapolis City Council is generating the criticisms of landlords across the city. Championed by Council Members Lisa Bender and Jeremiah Ellison, the ordinance is set to change how landlords screen prospective tenants. Its aim: to improve accessibility to the city’s housing [&hellip;]" />
					<meta name="description" content="Landlords push back on Minneapolis proposal to limit tenant screeningsA proposed ordinance by the Minneapolis City Council is generating the criticisms of landlords across the city. Championed by Council Members Lisa Bender and Jeremiah Ellison, the ordinance is set to change how landlords screen prospective tenants. Its aim: to improve accessibility to the city’s housing [&hellip;]" />
			<meta property="og:site_name" content="Twin Cities Daily Planet" /><meta property="og:image" content="https://www.tcdailyplanet.net/wp-content/uploads/2019/06/3344771391_e73b2404ed_o-e1559701956620.jpg" /><link rel="shortcut icon" href="https://www.tcdailyplanet.net/wp-content/uploads/2014/06/tcdp_inside_favicon1.ico"/><meta name="news_keywords" content="News, affordable housing, City council, Cuisine, Eric Phothisanh, Food Truck, Lao food, McKinley Community, Neighborhood association, north minneapolis"><meta name="original-source" content="https://www.tcdailyplanet.net/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/" /><meta name="syndication-source" content="https://www.tcdailyplanet.net/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/" /><meta name="standout" content="https://www.tcdailyplanet.net/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/"/>			<script>
			    var _gaq = _gaq || [];
							_gaq.push(['_setAccount', 'UA-1003974-1']);
				_gaq.push(['_trackPageview']);
										    _gaq.push(
					["largo._setAccount", "UA-17578670-4"],
					["largo._setCustomVar", 1, "SiteName", "Twin Cities Daily Planet"],
					["largo._setDomainName", "www.tcdailyplanet.net"],
					["largo._setAllowLinker", true],
					["largo._trackPageview"]
				);

			    (function() {
				    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
				    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
				    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
	

<!-- EventON Version -->
<meta name="generator" content="EventON 2.6.17" />

	<!-- Include google_services.js -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1000577/tcdp-leaderboard-728x90-wp', [728,90], "acm-ad-tag-tcdp-leaderboard-728x90-wp").addService(googletag.pubads());
googletag.defineSlot('/1000577/tcdp-sbmain-wp-01', [300,250], "acm-ad-tag-tcdp-sbmain-wp-01").addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>
</head>

<body class="post-template-default single single-post postid-2293557 single-format-standard classic">

	<div id="top"></div>

	
		<div class="global-nav-bg">
		<div class="global-nav">
			<nav id="top-nav" class="span12">
				<span class="visuallyhidden">
					<a href="#main" title="Skip to content">Skip to content</a>
				</span>
				<ul id="menu-global-navigation" class="menu"><li id="menu-item-208085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208085"><a href="https://www.tcdailyplanet.net/advertise/">Advertise</a></li>
<li id="menu-item-208086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208086"><a href="https://www.tcdailyplanet.net/contact-us/">Contact us</a></li>
<li id="menu-item-208087" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208087"><a href="https://www.tcdailyplanet.net/subscribe-to-newsletters/">Subscribe to Newsletters</a></li>
</ul>				<div class="nav-right">
											<ul id="header-social" class="social-icons visible-desktop">
							<li><a href="https://www.tcdailyplanet.net/?feed=rss2" title="Link to RSS Feed"><i class="icon-rss"></i></a></li><li><a href="https://facebook.com/tcdailyplanet" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/tcdailyplanet" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li>						</ul>
					<div class="donate-btn"><a href="http://www.tcdailyplanet.net/donate"><i class="icon-heart"></i>Donate Now</a></div> 
					<div id="header-search">
						<form class="form-search" role="search" method="get" action="https://www.tcdailyplanet.net/">
							<div class="input-append">
								<input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" /><button type="submit" class="search-submit btn">Go</button>
							</div>
						</form>
					</div>

				</div>
			</nav>
		</div> <!-- /.global-nav -->
	</div> <!-- /.global-nav-bg -->

	<div id="page" class="hfeed clearfix">

		
		<!---<div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
-->

		
<header id="site-header" class="clearfix dp-header-test branding" itemscope itemtype="http://schema.org/Organization">
<div class="row-fluid clearfix">
		<div class="span4 dp-header-test hidden-phone"><h2 class="visuallyhidden"><a itemprop="url" href="https://www.tcdailyplanet.net/"><span itemprop="name">Twin Cities Daily Planet</span> - <span class="tagline" itemprop="description">Amplifying and connecting marginalized voices</span></a></h2><a itemprop="url" href="https://www.tcdailyplanet.net/"><img class="header_img" src="" alt="" /></a></div>
		<div class="span8 dp-header-test hidden-phone" ><div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
</div>
	</div>
	<div class="row-fluid clearfix">
		<div class="span12 dp-header-test visible-phone"><h2 class="visuallyhidden"><a itemprop="url" href="https://www.tcdailyplanet.net/"><span itemprop="name">Twin Cities Daily Planet</span> - <span class="tagline" itemprop="description">Amplifying and connecting marginalized voices</span></a></h2><a itemprop="url" href="https://www.tcdailyplanet.net/"><img class="header_img" src="" alt="" /></a></div>
	</div>
	<div class="row-fluid clearfix">
		<!--<div class="span12 dp-header-test visible-phone" ><div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
</div>-->
	</div>
	

			

		
</header>
<header class="print-header">
	<p><strong>Twin Cities Daily Planet</strong> (https://www.tcdailyplanet.net/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/)</p>
</header>


		<nav id="main-nav" class="navbar clearfix">
	<div class="navbar-inner">
		<div class="container">
			<!-- .btn-navbar is used as the toggle for collapsed navbar content -->
			<a class="btn btn-navbar toggle-nav-bar"  title="More">
				<div class="bars">
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
				</div>
			</a>

			<div class="nav-shelf">
				<ul class="nav">
					<li id="menu-item-208065" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-208065"><a href="https://www.tcdailyplanet.net/">Home</a></li>
<li id="menu-item-638045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-638045"><a href="https://www.tcdailyplanet.net/about-2/">About</a></li>
<li id="menu-item-208096" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-208096"><a href="https://www.tcdailyplanet.net/category/news/">News + Features</a></li>
<li id="menu-item-307496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-307496"><a href="https://www.tcdailyplanet.net/category/arts/">Arts + Culture</a></li>
<li id="menu-item-208098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-208098"><a href="https://www.tcdailyplanet.net/category/community-voices/">Community Voices</a></li>
<li id="menu-item-379992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-379992"><a href="https://www.tcdailyplanet.net/category/blogs/">Blogs</a></li>
<li id="menu-item-208066" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-208066"><a href="#" class="dropdown-toggle">Partners <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li id="menu-item-208067" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208067"><a href="https://www.tcdailyplanet.net/partner_type/contributing-blogs/">Contributing Blogs</a></li>
	<li id="menu-item-208068" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208068"><a href="https://www.tcdailyplanet.net/partner_type/community-media/">Community Media</a></li>
	<li id="menu-item-208069" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208069"><a href="https://www.tcdailyplanet.net/partner_type/arts-media/">Arts Media</a></li>
	<li id="menu-item-208070" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208070"><a href="https://www.tcdailyplanet.net/partner_type/ethnic-media/">Ethnic Media</a></li>
	<li id="menu-item-208071" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208071"><a href="https://www.tcdailyplanet.net/partner_type/neighborhood-associations/">Neighborhood Associations</a></li>
</ul>
</li>
<li id="menu-item-675422" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-675422"><a href="https://www.tcdailyplanet.net/event-directory/">Events</a></li>
<li id="menu-item-675423" class="menu-item menu-item-type-taxonomy menu-item-object-event_type menu-item-675423"><a href="https://www.tcdailyplanet.net/event-type/classes/">Classes</a></li>
<li id="menu-item-617426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-617426"><a href="https://www.tcdailyplanet.net/work-with-us/">Work with Us</a></li>
				</ul>

				<ul class="nav visible-phone">
										<li class="menu-item-has-childen dropdown">
						<a href="javascript:void(0);" class="dropdown-toggle">Global Navigation <b class="caret"></b>
						</a>
						<ul id="menu-global-navigation-1" class="dropdown-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208085"><a href="https://www.tcdailyplanet.net/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208086"><a href="https://www.tcdailyplanet.net/contact-us/">Contact us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208087"><a href="https://www.tcdailyplanet.net/subscribe-to-newsletters/">Subscribe to Newsletters</a></li>
</ul>					</li>
									</ul>
			</div>
		</div>
	</div>
</nav>
<nav id="secondary-nav" class="clearfix">
	<div id="topics-bar" class="span12 hidden-phone">
		<ul id="menu-dont-miss" class="menu"><li class="menu-label"></li></ul>	</div>
</nav>


		
		
		<div id="main" class="row-fluid clearfix">

		
<div id="content" class="span8" role="main">

	
<article id="post-2293557" class="hnews item post-2293557 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-affordable-housing tag-city-council tag-cuisine tag-eric-phothisanh tag-food-truck tag-lao-food tag-mckinley-community tag-neighborhood-association tag-north-minneapolis tag-ordinance tag-racial-disparities tag-sabrina-boualaphanh tag-serendripity-spot-coffee-shop tag-soul-lao prominence-category-featured prominence-series-featured prominence-homepage-featured prominence-top-story" itemscope itemtype="http://schema.org/Article">

	
	<header>

 		<h1 class="entry-title" itemprop="headline">Best of Neighborhoods News 06/05/2019: Landlords push back on Minneapolis proposal to limit tenant screenings</h1>
 		<h5 class="byline"><span class="by-author"><span class="by">By</span> <span class="author vcard" itemprop="author"><a class="url fn n" href="https://www.tcdailyplanet.net/author/bee/" title="Read All Posts By Bee Vang" rel="author">Bee Vang</a></span></span><span class="sep"> | </span><time class="entry-date updated dtstamp pubdate" datetime="2019-06-05T03:00:57-05:00"><span class="time-ago">42 mins ago</span></time></h5>

 		<div class="post-social clearfix"><div class="left"><span class="twitter"><a href="http://twitter.com/share" class="twitter-share-button" data-url="https://www.tcdailyplanet.net/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/" data-text="Best of Neighborhoods News 06/05/2019: Landlords push back on Minneapolis proposal to limit tenant screenings" data-via="tcdailyplanet" data-via="" >Tweet</a></span><span class="facebook"><fb:like href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/" send="false" layout="button_count" show_faces="false" action="like"></fb:like></span></div><div class="right"><span class="print"><a href="#" onclick="window.print()" title="Print this article" rel="nofollow"><i class="icon-print"></i> Print</a></span><span data-service="email" class="email custom-share-button icon-mail share-button"> Email</span></div></div>
 		<meta itemprop="description" content="
Landlords push back on Minneapolis proposal to limit tenant screeningsA proposed ordinance by the Minneapolis City Council is generating the criticisms of landlords across the city. Championed by Council Members Lisa Bender and Jeremiah Ellison, the ordinance is set to change how landlords screen prospective tenants. Its aim: to improve accessibility to the city’s housing system and to address the growing racial disparities borne out of the city’s affordable housing crisis. The ordinance would prevent landlords “from rejecting applicants with an insufficient credit or rental history” and those “who have committed crimes that are no longer illegal in Minnesota.”
What will become of the ordinance remains to be seen, as a public hearing on it will be set for later this summer. For more, read Bring Me The News. 

Related stories:


Best of Neighborhood News 1/29: Minneapolis City Council discusses combating sex trafficking during Super Bowl LII

Best of Neighborhood News 1/2: University of Minnesota names its first female president

Best of Neighborhood News 03/26/19: a lesson plan for every student

Best of Neighborhoods News 05/15/2019: ‘Missing Middle’ housing pilot program


" />
<meta itemprop="datePublished" content="2019-06-05T03:00:57-05:00" />
<meta itemprop="dateModified" content="2019-06-04T21:50:02-05:00" />
<meta itemprop="image" content="https://www.tcdailyplanet.net/wp-content/uploads/2019/06/3344771391_e73b2404ed_o-140x140.jpg" />
	</header><!-- / entry header -->

			<div class="hero  is-image">
		<div class="dp-featured-image-container"><div class="dp-featured-image clearfix"><img width="771" height="578" src="https://www.tcdailyplanet.net/wp-content/uploads/2019/06/3344771391_e73b2404ed_o-e1559701956620.jpg" class="attachment-full size-full wp-post-image" alt="" /></div><div class="dp-credit clearfix"><p class="dp-media-credit"></p></div><div class="dp-caption">Photo by Cincy Project via Flickr.</div></div>	</div>
	
	<div class="entry-content clearfix" itemprop="articleBody">
		
<p><strong>Landlords push back on Minneapolis proposal to limit tenant screenings</strong><br>A proposed ordinance by the Minneapolis City Council is generating the criticisms of landlords across the city. Championed by Council Members Lisa Bender and Jeremiah Ellison, the ordinance is set to change how landlords screen prospective tenants. Its aim: to improve accessibility to the city’s housing system and to address the growing racial disparities borne out of the city’s affordable housing crisis. The ordinance would prevent landlords “from rejecting applicants with an insufficient credit or rental history” and those “who have committed crimes that are no longer illegal in Minnesota.”</p>



<p>What will become of the ordinance remains to be seen, as a public hearing on it will be set for later this summer.</p>



<p>For more, read <a href="https://bringmethenews.com/minnesota-news/landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings" target="_blank" rel="noreferrer noopener" aria-label=" (opens in a new tab)">Bring Me The News</a>.</p>



<p><strong>Under new leadership, McKinley neighborhood makes a comeback</strong><br>McKinley Community (MC), a Minneapolis neighborhood association, underwent significant transformation over the last three years, after having been stymied by controversy and internal struggles. Known specifically for the McKinley neighborhood in North Minneapolis, MC has earned newfound engagement, just as it recently opened its board to local community members. New leadership and devoted residents are hoping to recenter community voice as upcoming changes, such as the Upper Harbor Terminal Development, looms. </p>



<p>The closure of Serendripity Spot Coffee Shop on Lyndale Avenue, where MC will reopen its doors, will bring “new ways to build community power, while exploring community members’ capacities to engage in organizational work.”</p>



<p>Read the full story on <a href="https://mynorthnews.org/new-blog/mckinley-makes-comeback" target="_blank" rel="noreferrer noopener" aria-label=" (opens in a new tab)">My North News</a>. </p>



<p><strong>Soul Lao: On making the case for Lao food in Minnesota</strong><br>Coalescences of a country’s culturally rich, palatable cuisine come together as the staple of a food truck phenom in the Twin Cities known as “Soul Lao.” Its co-owners, Eric Phothisanh and Sabrina Boualaphanh, highlight the foods of the lesser-known, landlocked country of Laos, a country that belongs to the tragic history of the U.S. involvement in the French-Indochina wars in Southeast Asia. It is a country that is often elided when discussing Southeast Asia. Part of their impetus, both Phothisanh and Boualaphanh’s, is to give Lao cuisine its much-needed platform on the global scene.</p>



<p>“We had been told that Thai food would do well, but Lao food can’t go that far. Our food isn’t Instagram-ready. [It’s] messy, it’s funky, it’s spicy. We want to represent the underrepresented,” Boualaphanh explained.</p>



<p>Check the story on <a href="https://www.insightnews.com/lifestyle/soul-lao-on-making-the-case-for-lao-food-in/article_9a1f705a-835d-11e9-a101-6b37b6604053.html" target="_blank" rel="noreferrer noopener" aria-label=" (opens in a new tab)">Insight News</a>. </p>
<div class='yarpp-related'>
<h3>Related stories:</h3>
<div class="yarpp-thumbnails-horizontal">
<a class='yarpp-thumbnail' href='https://www.tcdailyplanet.net/best-of-neighborhood-news-1-29-minneapolis-city-council-discusses-combating-sex-trafficking-during-super-bowl-lii/' title='Best of Neighborhood News 1/29: Minneapolis City Council discusses combating sex trafficking during Super Bowl LII'>
<img width="120" height="120" src="https://www.tcdailyplanet.net/wp-content/uploads/2018/01/Phillipe_Council-120x120.jpg" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2018/01/Phillipe_Council-120x120.jpg 120w, https://www.tcdailyplanet.net/wp-content/uploads/2018/01/Phillipe_Council-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2018/01/Phillipe_Council-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2018/01/Phillipe_Council-32x32.jpg 32w, https://www.tcdailyplanet.net/wp-content/uploads/2018/01/Phillipe_Council-50x50.jpg 50w, https://www.tcdailyplanet.net/wp-content/uploads/2018/01/Phillipe_Council-64x64.jpg 64w, https://www.tcdailyplanet.net/wp-content/uploads/2018/01/Phillipe_Council-96x96.jpg 96w, https://www.tcdailyplanet.net/wp-content/uploads/2018/01/Phillipe_Council-128x128.jpg 128w" sizes="(max-width: 120px) 100vw, 120px" /><span class="yarpp-thumbnail-title">Best of Neighborhood News 1/29: Minneapolis City Council discusses combating sex trafficking during Super Bowl LII</span></a>
<a class='yarpp-thumbnail' href='https://www.tcdailyplanet.net/best-of-neighborhood-news-1-2-university-of-minnesota-names-its-first-female-president/' title='Best of Neighborhood News 1/2: University of Minnesota names its first female president'>
<img width="120" height="120" src="https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-120x120.jpg" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-120x120.jpg 120w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-32x32.jpg 32w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-50x50.jpg 50w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-64x64.jpg 64w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-96x96.jpg 96w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-128x128.jpg 128w" sizes="(max-width: 120px) 100vw, 120px" /><span class="yarpp-thumbnail-title">Best of Neighborhood News 1/2: University of Minnesota names its first female president</span></a>
<a class='yarpp-thumbnail' href='https://www.tcdailyplanet.net/best-of-neighborhood-news-03-26-19/' title='Best of Neighborhood News 03/26/19: a lesson plan for every student'>
<img width="120" height="120" src="https://www.tcdailyplanet.net/wp-content/uploads/2019/03/Kenny-teacher-1-web-120x120.jpg" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2019/03/Kenny-teacher-1-web-120x120.jpg 120w, https://www.tcdailyplanet.net/wp-content/uploads/2019/03/Kenny-teacher-1-web-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2019/03/Kenny-teacher-1-web-60x60.jpg 60w" sizes="(max-width: 120px) 100vw, 120px" /><span class="yarpp-thumbnail-title">Best of Neighborhood News 03/26/19: a lesson plan for every student</span></a>
<a class='yarpp-thumbnail' href='https://www.tcdailyplanet.net/best-of-neighborhoods-news-05-15-2019-missing-middle-housing-pilot-program/' title='Best of Neighborhoods News 05/15/2019: ‘Missing Middle’ housing pilot program'>
<img width="120" height="120" src="https://www.tcdailyplanet.net/wp-content/uploads/2019/05/Missing-middle-8-120x120.png" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2019/05/Missing-middle-8-120x120.png 120w, https://www.tcdailyplanet.net/wp-content/uploads/2019/05/Missing-middle-8-140x140.png 140w, https://www.tcdailyplanet.net/wp-content/uploads/2019/05/Missing-middle-8-60x60.png 60w" sizes="(max-width: 120px) 100vw, 120px" /><span class="yarpp-thumbnail-title">Best of Neighborhoods News 05/15/2019: ‘Missing Middle’ housing pilot program</span></a>
</div>
</div>
	</div><!-- .entry-content -->

	
	<footer class="post-meta bottom-meta">

    
	</footer><!-- /.post-meta -->

	
</article><!-- #post-2293557 -->
	<div id="comments" class="clearfix">
	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.tcdailyplanet.net/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='2293557' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2f5d3e437f" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="205"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->
</div>


<aside id="sidebar" class="span4">
		<div class="widget-area " role="complementary">
		<aside id="acm_ad_zones-10" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-sbmain-wp-01' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-sbmain-wp-01'); });
</script>
		</div>
		</aside><aside id="text-6" class="widget widget-2 even default widget_text clearfix"><h3 class="widgettitle">Submit an event</h3>			<div class="textwidget">Please complete the  <a href="http://www.tcdailyplanet.net/event-submission/">form here</a> to submit an event to our calendar.</div>
		</aside><aside id="text-4" class="widget widget-3 odd default widget_text clearfix"><h3 class="widgettitle">Tweets from TC Daily Planet</h3>			<div class="textwidget"><a class="twitter-timeline" href="https://twitter.com/tcdailyplanet" data-widget-id="548900467502096384">Tweets by @tcdailyplanet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		</aside><aside id="largo-featured-widget-5" class="widget widget-4 even default largo-featured clearfix"><h3 class="widgettitle">Today&#8217;s top stories</h3>			<div class="post-lead clearfix">
			<img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2019/06/3344771391_e73b2404ed_o-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2019/06/3344771391_e73b2404ed_o-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2019/06/3344771391_e73b2404ed_o-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2019/06/3344771391_e73b2404ed_o-120x120.jpg 120w" sizes="(max-width: 60px) 100vw, 60px" />			<h5><a href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/">Best of Neighborhoods News 06/05/2019: Landlords push back on Minneapolis proposal to limit tenant screenings</a></h5>
						<p>
Landlords push back on Minneapolis proposal to limit tenant screeningsA proposed ordinance by the Minneapolis City Council is generating the criticisms of landlords across the city. </p>				</div> <!-- /.post-lead -->
					<div class="post-lead clearfix">
			<img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2019/05/TrailerPark640-60x60.png" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2019/05/TrailerPark640-60x60.png 60w, https://www.tcdailyplanet.net/wp-content/uploads/2019/05/TrailerPark640-140x140.png 140w, https://www.tcdailyplanet.net/wp-content/uploads/2019/05/TrailerPark640-120x120.png 120w" sizes="(max-width: 60px) 100vw, 60px" />			<h5><a href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-05-29-2019-rep-ilhan-omar-introduces-bill-to-ease-path-for-mobile-home-residents-to-buy-their-parks/">Best of Neighborhoods News 05/29/2019: Rep. Ilhan Omar introduces bill to ease path for mobile home residents to buy their parks</a></h5>
						<p>
Rep. Ilhan Omar introduces bill to ease path for mobile home residents to buy their parksFrank Adelmann was a resident, of many, evicted from Lowry Grove, a mobile park in the city of St. </p>				</div> <!-- /.post-lead -->
					<div class="post-lead clearfix">
			<img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2019/05/2e7e7ad0-4cce-4e09-ba5f-aa478122d7f2.sized-1000x1000-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2019/05/2e7e7ad0-4cce-4e09-ba5f-aa478122d7f2.sized-1000x1000-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2019/05/2e7e7ad0-4cce-4e09-ba5f-aa478122d7f2.sized-1000x1000-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2019/05/2e7e7ad0-4cce-4e09-ba5f-aa478122d7f2.sized-1000x1000-120x120.jpg 120w" sizes="(max-width: 60px) 100vw, 60px" />			<h5><a href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-05-21-2019-umn-student-government-reaffirms-push-to-rename-campus-buildings/">Best of Neighborhoods News 05/21/2019: UMN student government reaffirms push to rename campus buildings</a></h5>
						<p>
UMN student government reaffirms push to rename campus buildingsThe Minnesota Student Association released a letter in the wake of a decision that came after nearly a year-long contention over four University of Minnesota campus buildings named after figures with racist, anti-semitic pasts. </p>				</div> <!-- /.post-lead -->
				
		</aside><aside id="largo-explore-related-widget-2" class="widget widget-5 odd default largo-explore-related clearfix">
			<div id="related-posts" class="idTabs row-fluid clearfix">
				<ul id="related-post-nav" class="span4">
					<li><h5>In case you missed it</h5></li>
					<li><a href="#rp0">News</a></li><li><a href="#rp1">affordable housing</a></li><li><a href="#rp2">north minneapolis</a></li><li><a href="#rp3">racial disparities</a></li>				</ul>

				<div class="related-items span8">
											<div id="rp0">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-05-29-2019-rep-ilhan-omar-introduces-bill-to-ease-path-for-mobile-home-residents-to-buy-their-parks/" title="Read Best of Neighborhoods News 05/29/2019: Rep. Ilhan Omar introduces bill to ease path for mobile home residents to buy their parks">Best of Neighborhoods News 05/29/2019: Rep. Ilhan Omar introduces bill to ease path for mobile home residents to buy their parks</a></h3><a href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-05-29-2019-rep-ilhan-omar-introduces-bill-to-ease-path-for-mobile-home-residents-to-buy-their-parks/"/><img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2019/05/TrailerPark640-60x60.png" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2019/05/TrailerPark640-60x60.png 60w, https://www.tcdailyplanet.net/wp-content/uploads/2019/05/TrailerPark640-140x140.png 140w, https://www.tcdailyplanet.net/wp-content/uploads/2019/05/TrailerPark640-120x120.png 120w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>
Rep. Ilhan Omar introduces bill to ease path for mobile home residents to buy their parksFrank Adelmann was a resident, of many, evicted from Lowry Grove, a mobile park in the city of St. Anthony that was home to nearly 100 families. </p>								</li>
								<li><a href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-05-21-2019-umn-student-government-reaffirms-push-to-rename-campus-buildings/" title="News">Best of Neighborhoods News 05/21/2019: UMN student government reaffirms push to rename campus buildings</a></li><li><a href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-05-15-2019-missing-middle-housing-pilot-program/" title="News">Best of Neighborhoods News 05/15/2019: ‘Missing Middle’ housing pilot program</a></li>							</ul>

							<p><a href="https://www.tcdailyplanet.net/category/news/" title="News" target="_blank"><strong>View all News Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
											<div id="rp1">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-05-15-2019-missing-middle-housing-pilot-program/" title="Read Best of Neighborhoods News 05/15/2019: ‘Missing Middle’ housing pilot program">Best of Neighborhoods News 05/15/2019: ‘Missing Middle’ housing pilot program</a></h3><a href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-05-15-2019-missing-middle-housing-pilot-program/"/><img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2019/05/Missing-middle-8-60x60.png" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2019/05/Missing-middle-8-60x60.png 60w, https://www.tcdailyplanet.net/wp-content/uploads/2019/05/Missing-middle-8-140x140.png 140w, https://www.tcdailyplanet.net/wp-content/uploads/2019/05/Missing-middle-8-120x120.png 120w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>
Wanted: ‘Missing Middle’ housingThe city of Minneapolis’ draft plan, Minneapolis 2040, includes a currently dubbed “Missing Middle” pilot program. The pilot will finance the cost-effective development of affordable housing inside new 3-to-20 unit buildings. </p>								</li>
								<li><a href="https://www.tcdailyplanet.net/best-of-neighborhood-news-7-19-corcoran-tenants-rally-for-renters-rights-affordable-housing/" title="affordable housing">Best of Neighborhood News 7/19: Corcoran tenants rally for renters’ rights, affordable housing</a></li><li><a href="https://www.tcdailyplanet.net/best-of-neighborhood-news-1-29-minneapolis-city-council-discusses-combating-sex-trafficking-during-super-bowl-lii/" title="affordable housing">Best of Neighborhood News 1/29: Minneapolis City Council discusses combating sex trafficking during Super Bowl LII</a></li>							</ul>

							<p><a href="https://www.tcdailyplanet.net/tag/affordable-housing/" title="affordable housing" target="_blank"><strong>View all affordable housing Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
											<div id="rp2">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="https://www.tcdailyplanet.net/best-of-neighborhood-news-1-2-university-of-minnesota-names-its-first-female-president/" title="Read Best of Neighborhood News 1/2: University of Minnesota names its first female president">Best of Neighborhood News 1/2: University of Minnesota names its first female president</a></h3><a href="https://www.tcdailyplanet.net/best-of-neighborhood-news-1-2-university-of-minnesota-names-its-first-female-president/"/><img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-32x32.jpg 32w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-50x50.jpg 50w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-64x64.jpg 64w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-96x96.jpg 96w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-128x128.jpg 128w, https://www.tcdailyplanet.net/wp-content/uploads/2019/01/Joan-Gabel-120x120.jpg 120w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>University of Minnesota names its first female president 

The Board of Regents voted to confirm Joan Gabel with a five-year contract as the next president of the university. Gabel visited all five campuses during the interview process and answered questions about her vision of higher education. </p>								</li>
								<li><a href="https://www.tcdailyplanet.net/councilmember-phillipe-cunningham-hosts-forum-speaks-out-on-the-2040-plan-in-minneapolis/" title="north minneapolis">Best of Neighborhood News 8/1/18: Councilmember Phillipe Cunningham hosts forum, speaks out on the 2040 Plan in Minneapolis</a></li><li><a href="https://www.tcdailyplanet.net/best-of-neighborhood-news-4-4-new-minnesota-house-bill-could-limit-snap-food-benefits/" title="north minneapolis">Best of Neighborhood News 4/4: New Minnesota House bill could limit SNAP food benefits</a></li>							</ul>

							<p><a href="https://www.tcdailyplanet.net/tag/north-minneapolis/" title="north minneapolis" target="_blank"><strong>View all north minneapolis Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
											<div id="rp3">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="https://www.tcdailyplanet.net/best-of-neighborhood-news-03-26-19/" title="Read Best of Neighborhood News 03/26/19: a lesson plan for every student">Best of Neighborhood News 03/26/19: a lesson plan for every student</a></h3><a href="https://www.tcdailyplanet.net/best-of-neighborhood-news-03-26-19/"/><img width="60" height="60" src="https://www.tcdailyplanet.net/wp-content/uploads/2019/03/Kenny-teacher-1-web-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="https://www.tcdailyplanet.net/wp-content/uploads/2019/03/Kenny-teacher-1-web-60x60.jpg 60w, https://www.tcdailyplanet.net/wp-content/uploads/2019/03/Kenny-teacher-1-web-140x140.jpg 140w, https://www.tcdailyplanet.net/wp-content/uploads/2019/03/Kenny-teacher-1-web-120x120.jpg 120w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>
A lesson plan for every studentA $2.6 million initiative is bringing change to classrooms in elementary and middle schools across Minneapolis this fall. Every school in the district will be able to hire “a differentiation specialist – a licensed teacher who will help meet the varying academic needs of students.” The pedagogy of differentiation is that teaching is predicated on student differences, above all else; differentiation is about this need to differentiate instruction effectively. </p>								</li>
								<li><a href="https://www.tcdailyplanet.net/best-of-neighborhood-news-1-30-19-naacp-chapters-unite-to-target-states-racial-wealth-gap/" title="racial disparities">Best of Neighborhood News 1/30/19: NAACP chapters unite to target state’s racial wealth gap</a></li><li><a href="https://www.tcdailyplanet.net/best-of-neighborhood-news-12-6-one-minnesota-governor-transition-advisory-board-assembled/" title="racial disparities">Best of Neighborhood News 12/6: One Minnesota governor transition advisory board assembled</a></li>							</ul>

							<p><a href="https://www.tcdailyplanet.net/tag/racial-disparities/" title="racial disparities" target="_blank"><strong>View all racial disparities Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
									</div> <!-- /.items -->
			</div> <!-- /#related-posts -->
		</aside>	</div>
	</aside>

	</div> <!-- #main -->

</div><!-- #page -->


<div class="footer-bg clearfix">
	<footer id="site-footer">

		<div id="supplementary" class="row-fluid">
	
	<div class="span4 widget-area" role="complementary">
		<ul id="menu-footer-navigation" class="menu"><li class="menu-label"></li><li id="menu-item-307252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-307252"><a href="https://www.tcdailyplanet.net/67262-2/">20/20 Tips for Community Journalists</a></li>
</ul>	</div>

	<div class="span4 widget-area" role="complementary">
		<aside id="text-7" class="widget widget-1 odd default widget_text clearfix">			<div class="textwidget"></div>
		</aside>	</div>

	<div class="span4 widget-area" role="complementary">
		<div class="widget widget_search"><h2 class="widgettitle">Search This Site</h2>
	<form class="form-search" role="search" method="get" action="https://www.tcdailyplanet.net/">
		<div>
			<input type="text" placeholder="Search" class="searchbox search-query" value="" name="s" />
			<input type="submit" value="Go" name="search submit" class="search-submit btn">
		</div>
	</form>

</div><div class="widget widget_archive"><h2 class="widgettitle">Browse Archives</h2>		<label class="screen-reader-text" for="archives-dropdown--1">Browse Archives</label>
		<select id="archives-dropdown--1" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://www.tcdailyplanet.net/2019/06/'> June 2019 </option>
	<option value='https://www.tcdailyplanet.net/2019/05/'> May 2019 </option>
	<option value='https://www.tcdailyplanet.net/2019/04/'> April 2019 </option>
	<option value='https://www.tcdailyplanet.net/2019/03/'> March 2019 </option>
	<option value='https://www.tcdailyplanet.net/2019/02/'> February 2019 </option>
	<option value='https://www.tcdailyplanet.net/2019/01/'> January 2019 </option>
	<option value='https://www.tcdailyplanet.net/2018/12/'> December 2018 </option>
	<option value='https://www.tcdailyplanet.net/2018/11/'> November 2018 </option>
	<option value='https://www.tcdailyplanet.net/2018/10/'> October 2018 </option>
	<option value='https://www.tcdailyplanet.net/2018/09/'> September 2018 </option>
	<option value='https://www.tcdailyplanet.net/2018/08/'> August 2018 </option>
	<option value='https://www.tcdailyplanet.net/2018/07/'> July 2018 </option>
	<option value='https://www.tcdailyplanet.net/2018/06/'> June 2018 </option>
	<option value='https://www.tcdailyplanet.net/2018/05/'> May 2018 </option>
	<option value='https://www.tcdailyplanet.net/2018/04/'> April 2018 </option>
	<option value='https://www.tcdailyplanet.net/2018/03/'> March 2018 </option>
	<option value='https://www.tcdailyplanet.net/2018/02/'> February 2018 </option>
	<option value='https://www.tcdailyplanet.net/2018/01/'> January 2018 </option>
	<option value='https://www.tcdailyplanet.net/2017/12/'> December 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/11/'> November 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/10/'> October 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/09/'> September 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/08/'> August 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/07/'> July 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/06/'> June 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/05/'> May 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/04/'> April 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/03/'> March 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/02/'> February 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/01/'> January 2017 </option>
	<option value='https://www.tcdailyplanet.net/2016/12/'> December 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/11/'> November 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/10/'> October 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/09/'> September 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/08/'> August 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/07/'> July 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/06/'> June 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/05/'> May 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/04/'> April 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/03/'> March 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/02/'> February 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/01/'> January 2016 </option>
	<option value='https://www.tcdailyplanet.net/2015/12/'> December 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/11/'> November 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/10/'> October 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/09/'> September 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/08/'> August 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/07/'> July 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/06/'> June 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/05/'> May 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/04/'> April 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/03/'> March 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/02/'> February 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/01/'> January 2015 </option>
	<option value='https://www.tcdailyplanet.net/2014/12/'> December 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/11/'> November 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/10/'> October 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/09/'> September 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/08/'> August 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/07/'> July 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/06/'> June 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/05/'> May 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/04/'> April 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/03/'> March 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/02/'> February 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/01/'> January 2014 </option>
	<option value='https://www.tcdailyplanet.net/2013/12/'> December 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/11/'> November 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/10/'> October 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/09/'> September 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/08/'> August 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/07/'> July 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/06/'> June 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/05/'> May 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/04/'> April 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/03/'> March 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/02/'> February 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/01/'> January 2013 </option>
	<option value='https://www.tcdailyplanet.net/2012/12/'> December 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/11/'> November 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/10/'> October 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/09/'> September 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/08/'> August 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/07/'> July 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/06/'> June 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/05/'> May 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/04/'> April 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/03/'> March 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/02/'> February 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/01/'> January 2012 </option>
	<option value='https://www.tcdailyplanet.net/2011/12/'> December 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/11/'> November 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/10/'> October 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/09/'> September 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/08/'> August 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/07/'> July 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/06/'> June 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/05/'> May 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/04/'> April 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/03/'> March 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/02/'> February 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/01/'> January 2011 </option>
	<option value='https://www.tcdailyplanet.net/2010/12/'> December 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/11/'> November 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/10/'> October 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/09/'> September 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/08/'> August 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/07/'> July 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/06/'> June 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/05/'> May 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/04/'> April 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/03/'> March 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/02/'> February 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/01/'> January 2010 </option>
	<option value='https://www.tcdailyplanet.net/2009/12/'> December 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/11/'> November 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/10/'> October 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/09/'> September 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/08/'> August 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/07/'> July 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/06/'> June 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/05/'> May 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/04/'> April 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/03/'> March 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/02/'> February 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/01/'> January 2009 </option>
	<option value='https://www.tcdailyplanet.net/2008/12/'> December 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/11/'> November 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/10/'> October 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/09/'> September 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/08/'> August 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/07/'> July 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/06/'> June 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/05/'> May 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/04/'> April 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/03/'> March 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/02/'> February 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/01/'> January 2008 </option>
	<option value='https://www.tcdailyplanet.net/2007/12/'> December 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/11/'> November 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/10/'> October 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/09/'> September 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/08/'> August 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/07/'> July 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/06/'> June 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/05/'> May 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/04/'> April 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/03/'> March 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/02/'> February 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/01/'> January 2007 </option>
	<option value='https://www.tcdailyplanet.net/2006/12/'> December 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/11/'> November 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/10/'> October 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/09/'> September 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/08/'> August 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/07/'> July 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/06/'> June 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/05/'> May 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/04/'> April 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/03/'> March 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/02/'> February 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/01/'> January 2006 </option>
	<option value='https://www.tcdailyplanet.net/2005/12/'> December 2005 </option>
	<option value='https://www.tcdailyplanet.net/2005/11/'> November 2005 </option>
	<option value='https://www.tcdailyplanet.net/2005/10/'> October 2005 </option>
	<option value='https://www.tcdailyplanet.net/2005/09/'> September 2005 </option>
	<option value='https://www.tcdailyplanet.net/2000/10/'> October 2000 </option>

		</select>

<script type='text/javascript'>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown--1" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</div>	</div>

	</div>
<div id="boilerplate">
	<div class="row-fluid clearfix">
		<div class="span9">
			<ul id="footer-social" class="social-icons">
				<li><a href="https://www.tcdailyplanet.net/?feed=rss2" title="Link to RSS Feed"><i class="icon-rss"></i></a></li><li><a href="https://facebook.com/tcdailyplanet" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/tcdailyplanet" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li>			</ul>
		</div>

			</div>

	<div class="row-fluid clearfix">
		<div class="span9">
			<div class="footer-bottom clearfix">

				<!-- If you enjoy this theme and use it on a production site we would appreciate it if you would leave the credit in place. Thanks :) -->
				<p class="footer-credit">&copy; Copyright 2019, Twin Cities Enterprise</p>
				<p class="footer-credit">This site built with <a href="http://largoproject.org">Project Largo</a> from <a href="http://inn.org">INN</a> and proudly powered by <a href="http://wordpress.org" rel="nofollow">WordPress</a>.</p>
			</div>
		</div>
		<div class="span3">
					</div>
	</div>

	<div class="row-fluid clearfix">
		<div class="span12">
			<p class="back-to-top"><a href="#top">Back to top &uarr;</a></p>
					</div>
	</div>
</div>

	</footer>
</div>

<div class="sticky-footer-holder">
	<div class="sticky-footer-container social-icons">

		
						<div class="comments">
			<a href="https://www.tcdailyplanet.net/best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings/#respond"><h4>Comment</h4> <i class="icon-comment"></i></a>
		</div>
		
		<div class="dismiss">
			<a href="#">
			<i class="icon-cancel"></i>
			</a>
		</div>

						<div class="follow">
			<h4>Follow</h4>

			<span class="post-category-link"><a href="https://www.tcdailyplanet.net/tag/affordable-housing/" title="Read Posts in the affordable housing category"><i class="icon-white icon-tag"></i>affordable housing</a></span>
																<div class="follow-author">
					<a href="https://www.tcdailyplanet.net/author/bee/feed/bee/" class="icon-rss"></a>
										<a href="https://www.tcdailyplanet.net/author/bee/">Bee Vang</a>
					</div>
							
		</div>

	</div>
</div>
<a rel="nofollow" style="display:none;" href="https://www.tcdailyplanet.net/?blackhole=e17e97d036">Do NOT follow this link or you will be banned from the site!</a>
		<script type="text/javascript" alt='evo_map_styles'>
		/*<![CDATA[*/
		var gmapstyles = 'default';
		/* ]]> */
		</script>		
				<script type="text/javascript">
			var LMP = {"ajax_url":"https:\/\/www.tcdailyplanet.net\/wp-admin\/admin-ajax.php","paged":0,"query":{"post__not_in":null,"page":"","name":"best-of-neighborhoods-news-06-05-2019-landlords-push-back-on-minneapolis-proposal-to-limit-tenant-screenings"},"is_home":false,"is_series_landing":false};
		</script>
	

		
		<!--Facebook-->
		<div id="fb-root"></div>
		<script>(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script>

		
		
		<!--Twitter-->
		<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

		
	<div class='evo_lightboxes' style='display:block'>					<div class='evo_lightbox eventcard eventon_events_list' id='' >
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose '>X</a>
									<div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'> </div>
								</div>
							</div>							
						</div>
					</div>
					</div><link rel='stylesheet' id='yarppRelatedCss-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=5.2.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/comment-reply.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/www/wp-content/themes/tcdailyplanet-largo-child/js/your_theme.js?ver=0.1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/load-more-posts.js'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/largoCore.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/largoPlugins.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/jquery.idTabs.js?ver=1.0'></script>
<script type='text/javascript' src='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/eventon_functions.js?ver=2.6.17'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/handlebars.js?ver=2.6.17'></script>
<script type='text/javascript' src='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/jquery.mobile.min.js?ver=2.6.17'></script>
<script type='text/javascript' src='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/jquery.mousewheel.min.js?ver=2.6.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var the_ajax_script = {"ajaxurl":"https:\/\/www.tcdailyplanet.net\/wp-admin\/admin-ajax.php","postnonce":"9992e5d766"};
/* ]]> */
</script>
<script type='text/javascript' src='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/eventon_script.js?ver=2.6.17'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/wp-embed.min.js?ver=5.2.1'></script>
<script async="async" type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/plugins/akismet/_inc/form.js?ver=4.1.1'></script>

</body>
</html>
