<!DOCTYPE html>
<!--[if lt IE 7]> <html lang="en-US" class="no-js ie6"> <![endif]-->
<!--[if IE 7]>    <html lang="en-US" class="no-js ie7"> <![endif]-->
<!--[if IE 8]>    <html lang="en-US" class="no-js ie8"> <![endif]-->
<!--[if IE 9]>    <html lang="en-US" class="no-js ie9"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>
	<meta charset="UTF-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0">
	<title>
		29th Annual Taste of Greece Festival | Twin Cities Daily Planet	</title>
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://www.tcdailyplanet.net/xmlrpc.php" />
		<script>
			function whichHeader() {
				var screenWidth = document.documentElement.clientWidth,
				header_img;
				if (screenWidth <= 767) {
					header_img = 'https://www.tcdailyplanet.net/wp-content/uploads/2014/06/DP-logo-without-5702-336x661-336x66.png';
				} else if (screenWidth > 767 && screenWidth <= 979) {
					header_img = 'https://www.tcdailyplanet.net/wp-content/uploads/2014/06/DP-logo-without-5702-336x662-336x66.png';
				} else {
					header_img = 'https://www.tcdailyplanet.net/wp-content/uploads/2014/06/DP-logo-without-5702-336x663-336x66.png';
				}
				return header_img;
			}
			var banner_img_src = whichHeader();
		</script>
	<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; Feed" href="https://www.tcdailyplanet.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; Comments Feed" href="https://www.tcdailyplanet.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; 29th Annual Taste of Greece Festival Comments Feed" href="https://www.tcdailyplanet.net/events/29th-annual-taste-of-greece-festival/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.tcdailyplanet.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slides-css'  href='https://www.tcdailyplanet.net/wp-content/themes/largo/lib/navis-slideshows/css/slides.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slick-css'  href='https://www.tcdailyplanet.net/wp-content/themes/largo/lib/navis-slideshows/vendor/slick/slick.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='evo_sr_styles-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/eventon-search/assets/styles.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='evo_single_event-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/css/evo_event_styles.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='super-rss-reader-css-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/super-rss-reader/public/srr-css.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='largo-stylesheet-css'  href='https://www.tcdailyplanet.net/?ver=4.8.1&#038;largo_custom_less_variable=1&#038;css_file=style.min.css&#038;timestamp=0' type='text/css' media='all' />
<link rel='stylesheet' id='largo-child-styles-css'  href='https://www.tcdailyplanet.net/wp-content/themes/tcdailyplanet-largo-child/style.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A400%2C400i%2C300&#038;ver=4.8.1' type='text/css' media='screen' />
<link rel='stylesheet' id='evcal_cal_default-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/css/eventon_styles.css?ver=2.4.10' type='text/css' media='all' />
<link rel='stylesheet' id='evo_font_icons-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/fonts/font-awesome.css?ver=2.4.10' type='text/css' media='all' />
<link rel='stylesheet' id='eventon_dynamic_styles-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/css/eventon_dynamic_styles.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='evo_fc_styles-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/eventon-full-cal/assets/fc_styles.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='homepage-slider-css'  href='https://www.tcdailyplanet.net/wp-content/themes/largo/homepages/assets/css/top-stories.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='argo-links-css'  href='https://www.tcdailyplanet.net/wp-content/plugins/argo-links/css/argo-links.css?ver=1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/plugins/super-rss-reader/public/srr-js.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/modernizr.custom.js?ver=4.8.1'></script>
<link rel='https://api.w.org/' href='https://www.tcdailyplanet.net/wp-json/' />
<link rel='prev' title='Next Generation Artists Directing Institute: Informal Community' href='https://www.tcdailyplanet.net/events/next-generation-artists-directing-institute-informal-community/' />
<link rel='next' title='Ability Bash, Party With A Purpose' href='https://www.tcdailyplanet.net/events/ability-bash-party-with-a-purpose/' />
<link rel="canonical" href="https://www.tcdailyplanet.net/events/29th-annual-taste-of-greece-festival/" />
<link rel='shortlink' href='https://www.tcdailyplanet.net/?p=1203341' />
<link rel="alternate" type="application/json+oembed" href="https://www.tcdailyplanet.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tcdailyplanet.net%2Fevents%2F29th-annual-taste-of-greece-festival%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.tcdailyplanet.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tcdailyplanet.net%2Fevents%2F29th-annual-taste-of-greece-festival%2F&#038;format=xml" />
<link rel="stylesheet" href="https://www.tcdailyplanet.net/wp-content/plugins/multi-column-taxonomy-list/css/multi-column-taxonomy-link.css" type="text/css" />
		<meta name="twitter:card" content="summary">

		<meta name="twitter:site" content="@tcdailyplanet">
							<meta property="og:title" content="29th Annual Taste of Greece Festival" />
					<meta property="og:type" content="article" />
					<meta property="og:url" content="https://www.tcdailyplanet.net/events/29th-annual-taste-of-greece-festival/"/>
					<meta property="og:description" content="OPA! Minneapolis, MN – July 2017 – The 29th Minneapolis Greek Festival “Taste of Greece” will take place the weekend after Labor Day at St. Mary’s Greek Orthodox Church. The Taste of Greece runs Friday and Saturday, September 8 &#8211; 9, from noon to 10 pm, and Sunday, September 10, from noon to 6 pm. [&hellip;]" />
					<meta name="description" content="OPA! Minneapolis, MN – July 2017 – The 29th Minneapolis Greek Festival “Taste of Greece” will take place the weekend after Labor Day at St. Mary’s Greek Orthodox Church. The Taste of Greece runs Friday and Saturday, September 8 &#8211; 9, from noon to 10 pm, and Sunday, September 10, from noon to 6 pm. [&hellip;]" />
			<meta property="og:site_name" content="Twin Cities Daily Planet" /><meta property="og:image" content="https://www.tcdailyplanet.net/wp-content/uploads/2017/07/11261793_1168767509816269_455132197632997555_n.jpg" /><link rel="shortcut icon" href="https://www.tcdailyplanet.net/wp-content/uploads/2014/06/tcdp_inside_favicon1.ico"/><meta name="original-source" content="https://www.tcdailyplanet.net/events/29th-annual-taste-of-greece-festival/" /><meta name="syndication-source" content="https://www.tcdailyplanet.net/events/29th-annual-taste-of-greece-festival/" />			<script>
			    var _gaq = _gaq || [];
							_gaq.push(['_setAccount', 'UA-1003974-1']);
				_gaq.push(['_trackPageview']);
										    _gaq.push(
					["largo._setAccount", "UA-17578670-4"],
					["largo._setCustomVar", 1, "SiteName", "Twin Cities Daily Planet"],
					["largo._setDomainName", "www.tcdailyplanet.net"],
					["largo._setAllowLinker", true],
					["largo._trackPageview"]
				);

			    (function() {
				    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
				    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
				    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
	

<!-- EventON Version -->
<meta name="generator" content="EventON 2.4.10" />

				<meta name="robots" content="all"/>
				<meta property="description" content="OPA! Minneapolis, MN – July 2017 – The 29th Minneapolis Greek Festival “Taste of Greece” will take place the weekend" />
				<meta property="og:type" content="event" /> 
				<meta property="og:title" content="29th Annual Taste of Greece Festival" />
				<meta property="og:url" content="https://www.tcdailyplanet.net/events/29th-annual-taste-of-greece-festival/" />
				<meta property="og:description" content="OPA! Minneapolis, MN – July 2017 – The 29th Minneapolis Greek Festival “Taste of Greece” will take place the weekend" />
									<meta property="og:image" content="https://www.tcdailyplanet.net/wp-content/uploads/2017/07/11261793_1168767509816269_455132197632997555_n-336x362.jpg" /> 
					<meta property="og:image:width" content="336" /> 
					<meta property="og:image:height" content="362" /> 
									<!-- Include google_services.js -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1000577/tcdp-leaderboard-728x90-wp', [728,90], "acm-ad-tag-tcdp-leaderboard-728x90-wp").addService(googletag.pubads());
googletag.defineSlot('/1000577/tcdp-sbmain-wp-01', [300,250], "acm-ad-tag-tcdp-sbmain-wp-01").addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>
</head>

<body class="ajde_events-template-default single single-ajde_events postid-1203341">

	<div id="top"></div>

	
		<div class="global-nav-bg">
		<div class="global-nav">
			<nav id="top-nav" class="span12">
				<span class="visuallyhidden">
					<a href="#main" title="Skip to content">Skip to content</a>
				</span>
				<ul id="menu-global-navigation" class="menu"><li id="menu-item-208085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208085"><a href="https://www.tcdailyplanet.net/advertise/">Advertise</a></li>
<li id="menu-item-208086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208086"><a href="https://www.tcdailyplanet.net/contact-us/">Contact us</a></li>
<li id="menu-item-208087" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208087"><a href="https://www.tcdailyplanet.net/subscribe-newsletters/">Subscribe to Newsletters</a></li>
</ul>				<div class="nav-right">
											<ul id="header-social" class="social-icons visible-desktop">
							<li><a href="https://www.tcdailyplanet.net/?feed=rss2" title="Link to RSS Feed"><i class="icon-rss"></i></a></li><li><a href="https://facebook.com/tcdailyplanet" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/tcdailyplanet" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li>						</ul>
					<div class="donate-btn"><a href="http://www.tcdailyplanet.net/donate"><i class="icon-heart"></i>Donate Now</a></div> 
					<div id="header-search">
						<form class="form-search" role="search" method="get" action="https://www.tcdailyplanet.net/">
							<div class="input-append">
								<input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" /><button type="submit" class="search-submit btn">Go</button>
							</div>
						</form>
					</div>

				</div>
			</nav>
		</div> <!-- /.global-nav -->
	</div> <!-- /.global-nav-bg -->

	<div id="page" class="hfeed clearfix">

		
		<!---<div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
-->

		
<header id="site-header" class="clearfix dp-header-test branding" itemscope itemtype="http://schema.org/Organization">
<div class="row-fluid clearfix">
		<div class="span4 dp-header-test hidden-phone"><h2 class="visuallyhidden"><a itemprop="url" href="https://www.tcdailyplanet.net/"><span itemprop="name">Twin Cities Daily Planet</span> - <span class="tagline" itemprop="description">Amplifying and connecting marginalized voices</span></a></h2><a itemprop="url" href="https://www.tcdailyplanet.net/"><img class="header_img" src="" alt="" /></a></div>
		<div class="span8 dp-header-test hidden-phone" ><div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
</div>
	</div>
	<div class="row-fluid clearfix">
		<div class="span12 dp-header-test visible-phone"><h2 class="visuallyhidden"><a itemprop="url" href="https://www.tcdailyplanet.net/"><span itemprop="name">Twin Cities Daily Planet</span> - <span class="tagline" itemprop="description">Amplifying and connecting marginalized voices</span></a></h2><a itemprop="url" href="https://www.tcdailyplanet.net/"><img class="header_img" src="" alt="" /></a></div>
	</div>
	<div class="row-fluid clearfix">
		<!--<div class="span12 dp-header-test visible-phone" ><div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
</div>-->
	</div>
	

			

		
</header>
<header class="print-header">
	<p><strong>Twin Cities Daily Planet</strong> (https://www.tcdailyplanet.net/events/29th-annual-taste-of-greece-festival/)</p>
</header>


		<nav id="main-nav" class="navbar clearfix">
	<div class="navbar-inner">
		<div class="container">
			<!-- .btn-navbar is used as the toggle for collapsed navbar content -->
			<a class="btn btn-navbar toggle-nav-bar"  title="More">
				<div class="bars">
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
				</div>
			</a>

			<div class="nav-shelf">
				<ul class="nav">
					<li id="menu-item-208065" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-208065"><a href="https://www.tcdailyplanet.net/">Home</a></li>
<li id="menu-item-638045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-638045"><a href="https://www.tcdailyplanet.net/about-2/">About</a></li>
<li id="menu-item-208096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-208096"><a href="https://www.tcdailyplanet.net/category/news/">News + Features</a></li>
<li id="menu-item-307496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-307496"><a href="https://www.tcdailyplanet.net/category/arts/">Arts + Culture</a></li>
<li id="menu-item-208098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-208098"><a href="https://www.tcdailyplanet.net/category/community-voices/">Community Voices</a></li>
<li id="menu-item-379992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-379992"><a href="https://www.tcdailyplanet.net/category/blogs/">Blogs</a></li>
<li id="menu-item-208066" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-208066"><a href="#" class="dropdown-toggle">Partners <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li id="menu-item-208067" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208067"><a href="https://www.tcdailyplanet.net/partner_type/contributing-blogs/">Contributing Blogs</a></li>
	<li id="menu-item-208068" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208068"><a href="https://www.tcdailyplanet.net/partner_type/community-media/">Community Media</a></li>
	<li id="menu-item-208069" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208069"><a href="https://www.tcdailyplanet.net/partner_type/arts-media/">Arts Media</a></li>
	<li id="menu-item-208070" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208070"><a href="https://www.tcdailyplanet.net/partner_type/ethnic-media/">Ethnic Media</a></li>
	<li id="menu-item-208071" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208071"><a href="https://www.tcdailyplanet.net/partner_type/neighborhood-associations/">Neighborhood Associations</a></li>
</ul>
</li>
<li id="menu-item-675422" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-675422"><a href="https://www.tcdailyplanet.net/event-directory/">Events</a></li>
<li id="menu-item-675423" class="menu-item menu-item-type-taxonomy menu-item-object-event_type menu-item-675423"><a href="https://www.tcdailyplanet.net/event-type/classes/">Classes</a></li>
<li id="menu-item-617426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-617426"><a href="https://www.tcdailyplanet.net/work-with-us/">Work with Us</a></li>
				</ul>

				<ul class="nav visible-phone">
										<li class="menu-item-has-childen dropdown">
						<a href="javascript:void(0);" class="dropdown-toggle">Global Navigation <b class="caret"></b>
						</a>
						<ul id="menu-global-navigation-1" class="dropdown-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208085"><a href="https://www.tcdailyplanet.net/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208086"><a href="https://www.tcdailyplanet.net/contact-us/">Contact us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208087"><a href="https://www.tcdailyplanet.net/subscribe-newsletters/">Subscribe to Newsletters</a></li>
</ul>					</li>
									</ul>
			</div>
		</div>
	</div>
</nav>
<nav id="secondary-nav" class="clearfix">
	<div id="topics-bar" class="span12 hidden-phone">
		<ul id="menu-dont-miss" class="menu"><li class="menu-label"></li></ul>	</div>
</nav>


		
		
		<div id="main" class="row-fluid clearfix">

			
<div id='main'>
	<div class='evo_page_body'>
		<div class='evo_page_content '>
						
				<article id="post-1203341" class="post-1203341 ajde_events type-ajde_events status-publish has-post-thumbnail hentry event_location-st-marys-greek-orthodox-church event_organizer-katherine-pappas event_type-free-event">

					<div class="entry-content">

								<script> 
				href = window.location.href;
				var cleanurl = href.split('#');
				hash =  window.location.hash.substr(1);
				hash_ri = hash.split('=');

				if(hash_ri[1]){
					if(href.indexOf('?') >0){
						redirect = cleanurl[0]+'&ri='+hash_ri[1];
					}else{
						redirect = cleanurl[0]+'?ri='+hash_ri[1];
					}
					window.location.replace( redirect );
				}
			</script>
			<div class='eventon_main_section' >
	<div id='evcal_single_event_1203341' class='ajde_evcal_calendar eventon_single_event evo_sin_page ' >
		
		<div class='evo-data' data-mapformat="roadmap" data-mapzoom="18" data-mapscroll="true" data-evc_open="1" ></div>

		<div id='evcal_head' class='calendar_header'><p id='evcal_cur'>september, 2017</p></div>
		<div id='evcal_list' class='eventon_events_list evo_sin_event_list'>
		<div id="event_1203341" class="eventon_list_event  event" data-event_id="1203341" data-time="1504872000-1505066400" data-colr="#3b124a" itemscope itemtype='http://schema.org/Event'><div class="evo_event_schema" style="display:none" >
							<a href="https://www.tcdailyplanet.net/events/29th-annual-taste-of-greece-festival/" itemprop="url"></a>
							<time itemprop="startDate" datetime="2017-9-8"></time>
							<time itemprop="endDate" datetime="2017-9-10"></time>
									<item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place">
										<span itemprop="name">St. Mary’s Greek Orthodox Church</span>
										<span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress">
											<item itemprop="streetAddress">3450 Irving Avenue South, Minneapolis MN 55408</item>
										</span></item></div>
				<p class="desc_trig_outter"><a data-gmtrig="1" data-exlk="1" href="https://www.tcdailyplanet.net/events/29th-annual-taste-of-greece-festival/" style="border-color: #3b124a;" id="evc_15048720001203341" class="desc_trig gmaponload mul_val evcal_list_a" data-ux_val="4" ><span class='evcal_cblock ' data-bgcolor='#3b124a' data-smon='september' data-syr='2017'><em class='evo_date' ><span class="start">8<em>sep</em></span><span class="end"> - 10</span></em><span class='evo_time'><em class='evo_day'>sep 8</em><span class='start'>12:00 pm</span><em class='evo_day end'>sep 10</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="44.9396531,-93.3030662"  data-location_address="3450 Irving Avenue South, Minneapolis MN 55408" data-location_type="lonlat" data-location_name="St. Mary’s Greek Orthodox Church" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>29th Annual Taste of Greece Festival</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard open' style="display:block"><div class='evo_metarow_directimg'><img src='https://www.tcdailyplanet.net/wp-content/uploads/2017/07/11261793_1168767509816269_455132197632997555_n.jpg'/></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'>
							<div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>OPA! Minneapolis, MN – July 2017 – The 29th Minneapolis Greek Festival “Taste of Greece” will take place the weekend after Labor Day at St. Mary’s Greek Orthodox Church.

The Taste</p></div>
							<span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>
							<div class='evcal_evdata_cell shorter_desc'><div class='eventon_details_shading_bot'>
								<p class='eventon_shad_p' content='less'><span class='ev_more_text' data-txt='less'>more</span><span class='ev_more_arrow'></span></p>
							</div><div class='eventon_full_description'>
									<h3 class='padb5 evo_h3'>Event Details</h3><div class='eventon_desc_in' itemprop='description'>
									<p>OPA! Minneapolis, MN – July 2017 – The 29th Minneapolis Greek Festival “Taste of Greece” will take place the weekend after Labor Day at St. Mary’s Greek Orthodox Church.</p>
<p>The Taste of Greece runs <span class="aBn" data-term="goog_1044814816"><span class="aQJ">Friday</span></span> and <span class="aBn" data-term="goog_1044814817"><span class="aQJ">Saturday, September 8 &#8211; 9</span></span>, from <span class="aBn" data-term="goog_1044814818"><span class="aQJ">noon to 10 pm</span></span>, and <span class="aBn" data-term="goog_1044814819"><span class="aQJ">Sunday, September 10</span></span>, from <span class="aBn" data-term="goog_1044814820"><span class="aQJ">noon to 6 pm</span></span>. Early Bird Specials <span class="aBn" data-term="goog_1044814821"><span class="aQJ">on Friday</span></span> <span class="aBn" data-term="goog_1044814822"><span class="aQJ">noon &#8211; 4 pm</span></span>.</p>
<p>Taste of Greece will feature authentic Greek food, and handmade Greek desserts, including gluten-free options. The Levendes and the Chris Kalogerson Band will provide live Greek music, while the St. Mary’s Hellenic Dance Troupe will perform authentic Greek folk dances.</p>
<p>Church tours will be provided, and the always popular Greek Boutique will feature beautiful items. Fun inflatables will be available in the kid’s area and don’t forget to check out the Courtyard Café – with wine tasting and mezes &#8212; the sunsets are spectacular!</p>
<p>Proceeds from the Taste of Greece Festival go to support charitable organizations such as Joyce Food Shelf and St. Mary’s missions and outreach programs. Festival guests are encouraged to bring 3 non-perishable food items for Joyce Food Shelf (<a href="http://www.joycefoodshelf.org/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://www.joycefoodshelf.org/&amp;source=gmail&amp;ust=1499341799565000&amp;usg=AFQjCNEoj3vWA6ocHjnjsER_p7AKOOAvfg">http://www.joycefoodshelf.<wbr />org/</a>) and receive 2 free food tickets.</p>
<p><span class="aBn" data-term="goog_1044814823"><span class="aQJ">Friday</span></span> night the annual Chloe’s Fight 5K Toga Run/Family Walk and Kid’s Toga Race will take place at Lake Calhoun. All proceeds benefit pediatric rare disease research. Information and online registration at <a href="http://chloesfight.org/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://chloesfight.org/&amp;source=gmail&amp;ust=1499341799565000&amp;usg=AFQjCNF4mzAIQYdST4t5E40f7sNAtvXQbw">http://chloesfight.org/</a>.</p>
<p>“Each year we are happy to open our Church doors to our friends and neighbors to share our Greek culture and support several worthy causes,” said Fr. George Dokos, head priest at St. Mary’s.</p>
<p>St. Mary’s Greek Orthodox Church is located at 3450 Irving Avenue South, Minneapolis. More information available at<a href="http://mplsgreekfest.org/" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://mplsgreekfest.org/&amp;source=gmail&amp;ust=1499341799565000&amp;usg=AFQjCNFdt0GD2v1SRDR7DMQVpvc9xR18UQ">http://mplsgreekfest.org/</a>, <a href="https://www.facebook.com/mplsgreekfest" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=https://www.facebook.com/mplsgreekfest&amp;source=gmail&amp;ust=1499341799565000&amp;usg=AFQjCNGL8cZX4h4pkYsB2HSz4M99KTcEvg">https://www.facebook.com/<wbr />mplsgreekfest</a>, <a href="https://twitter.com/mplsgreekfest" target="_blank" rel="noopener" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=https://twitter.com/mplsgreekfest&amp;source=gmail&amp;ust=1499341799565000&amp;usg=AFQjCNFNZcDIfCl-oFXKaKUksclueigcLQ">https://twitter.com/<wbr />mplsgreekfest</a>.</p>
</div><div class='clear'></div>
								</div>
							</div>
						</div><div class='evo_metarow_time_location evorow bordb '>
						<div class='tb' >
							<div class='tbrow'>
							<div class='evcal_col50 bordr'>
								<div class='evcal_evdata_row evo_time'>
									<span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>
									<div class='evcal_evdata_cell'>							
										<h3 class='evo_h3'>Time</h3><p>8 (Friday) 12:00 pm - 10 (Sunday) 6:00 pm</p>
									</div>
								</div>
							</div><div class='evcal_col50'>
								<div class='evcal_evdata_row evo_location'>
									<span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>
									<div class='evcal_evdata_cell' data-loc_tax_id='27395'>							
										<h3 class='evo_h3'>Location</h3><p class='evo_location_name'>St. Mary’s Greek Orthodox Church</p><p>3450 Irving Avenue South, Minneapolis MN 55408</p>
									</div>
								</div>
							</div><div class='clear'></div>
							</div></div>
						</div><div class='evo_metarow_organizer evorow evcal_evdata_row bordb evcal_evrow_sm '>
							<span class='evcal_evdata_icons'><i class='fa fa-headphones'></i></span>
							<div class='evcal_evdata_cell'>							
								<h3 class='evo_h3'>Organizer</h3>
								
								<div class='evo_card_organizer'><p class='evo_data_val evo_card_organizer_name'>
									<span class='evo_card_organizer_name_t'><a  href='	http://mplsgreekfest.org/'>Katherine Pappas</a></span><span class='evo_card_organizer_contact'>kaypapps@gmail.com; 	(612) 825-9595</span>
									
									</p></div>								
							</div>
						</div><div class='evo_metarow_gmap evorow evcal_gmaps bordb ' id='evc150487200059b1154d539e11203341_gmap' style='max-width:none'></div>						<div class='evo_metarow_ICS evorow bordb evcal_evdata_row'>
							<span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span>
							<div class='evcal_evdata_cell'>
								<p><a href='https://www.tcdailyplanet.net/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=1203341&amp;sunix=1504872000&amp;eunix=1505066400' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='http://www.google.com/calendar/event?action=TEMPLATE&amp;text=29th+Annual+Taste+of+Greece+Festival&amp;dates=20170908T170000Z/20170910T230000Z&amp;details=OPA%21+Minneapolis%2C+MN+%E2%80%93+July+2017+%E2%80%93+The+29th+Minneapolis+Greek+Festival+%E2%80%9CTaste+of+Greece%E2%80%9D+will+take+place+the+weekend+after+Labor+Day+at+St.+Mary%E2%80%99s+Greek+Orthodox+Church.%0D%0A%0D%0AThe+Taste&amp;location=' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p>	
							</div>						</div>
						<div class='evo_metarow_getDr evorow evcal_evdata_row bordb evcal_evrow_sm getdirections'>
						<form action='https://maps.google.com/maps' method='get' target='_blank'>
						<input type='hidden' name='daddr' value='3450 Irving Avenue South, Minneapolis MN 55408'/> 
						<p><input class='evoInput' type='text' name='saddr' placeholder='Type your address to get directions' value=''/>
						<button type='submit' class='evcal_evdata_icons evcalicon_9' title='Click here to get directions'><i class='fa fa-road'></i></button>
						</p></form>
					</div></div><div class='clear end'></div></div>		</div>
	</div>
</div>

<div id='primary'>
	<div id="comments" class="clearfix">
	
	
			<h2 id="comments-title">
			One thought on &ldquo;<span>29th Annual Taste of Greece Festival</span>&rdquo;		</h2>

		
		<ol class="commentlist">
					<li class="comment even thread-even depth-1" id="li-comment-581848">
			<article id="comment-581848" class="comment">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/20394306b3c0b567a4734ada34ace60e?s=68&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/20394306b3c0b567a4734ada34ace60e?s=136&amp;d=mm&amp;r=g 2x' class='avatar avatar-68 photo' height='68' width='68' /><span class="fn">Jon</span> on <a href="https://www.tcdailyplanet.net/events/29th-annual-taste-of-greece-festival/#comment-581848"><time pubdate datetime="2017-09-06T16:46:37+00:00">September 6, 2017 at 4:46 pm</time></a> <span class="says">said:</span>
											</div><!-- .comment-author .vcard -->

					
				</footer>

				<div class="comment-content"><p>Looking forward to Gyros<br />
Hope they have them</p>
</div>

				<div class="reply">
					<a rel='nofollow' class='comment-reply-link' href='https://www.tcdailyplanet.net/events/29th-annual-taste-of-greece-festival/?replytocom=581848#respond' onclick='return addComment.moveForm( "comment-581848", "581848", "respond", "1203341" )' aria-label='Reply to Jon'>Reply <span>&darr;</span></a>				</div><!-- .reply -->
			</article><!-- #comment-## -->

		</li><!-- #comment-## -->
		</ol>

		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/events/29th-annual-taste-of-greece-festival/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.tcdailyplanet.net/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1203341' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e17d08bfa0" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="247"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->
</div>		
					</div><!-- .entry-content -->

					<footer class="entry-meta">
											</footer><!-- .entry-meta -->
				</article><!-- #post -->
			
		</div><!-- #content -->
	
			</div><!-- #primary -->
	<div class="clear"></div>

</div>	
	
	</div> <!-- #main -->

</div><!-- #page -->


<div class="footer-bg clearfix">
	<footer id="site-footer">

		<div id="supplementary" class="row-fluid">
	
	<div class="span4 widget-area" role="complementary">
		<ul id="menu-footer-navigation" class="menu"><li class="menu-label"></li><li id="menu-item-307252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-307252"><a href="https://www.tcdailyplanet.net/67262-2/">20/20 Tips for Community Journalists</a></li>
</ul>	</div>

	<div class="span4 widget-area" role="complementary">
		<aside id="text-7" class="widget widget-1 odd default widget_text clearfix">			<div class="textwidget"></div>
		</aside>	</div>

	<div class="span4 widget-area" role="complementary">
		<div class="widget widget_search"><h2 class="widgettitle">Search This Site</h2>
	<form class="form-search" role="search" method="get" action="https://www.tcdailyplanet.net/">
		<div>
			<input type="text" placeholder="Search" class="searchbox search-query" value="" name="s" />
			<input type="submit" value="Go" name="search submit" class="search-submit btn">
		</div>
	</form>

</div><div class="widget widget_archive"><h2 class="widgettitle">Browse Archives</h2>		<label class="screen-reader-text" for="archives-dropdown--1">Browse Archives</label>
		<select id="archives-dropdown--1" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://www.tcdailyplanet.net/2017/09/'> September 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/08/'> August 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/07/'> July 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/06/'> June 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/05/'> May 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/04/'> April 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/03/'> March 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/02/'> February 2017 </option>
	<option value='https://www.tcdailyplanet.net/2017/01/'> January 2017 </option>
	<option value='https://www.tcdailyplanet.net/2016/12/'> December 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/11/'> November 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/10/'> October 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/09/'> September 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/08/'> August 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/07/'> July 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/06/'> June 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/05/'> May 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/04/'> April 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/03/'> March 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/02/'> February 2016 </option>
	<option value='https://www.tcdailyplanet.net/2016/01/'> January 2016 </option>
	<option value='https://www.tcdailyplanet.net/2015/12/'> December 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/11/'> November 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/10/'> October 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/09/'> September 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/08/'> August 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/07/'> July 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/06/'> June 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/05/'> May 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/04/'> April 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/03/'> March 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/02/'> February 2015 </option>
	<option value='https://www.tcdailyplanet.net/2015/01/'> January 2015 </option>
	<option value='https://www.tcdailyplanet.net/2014/12/'> December 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/11/'> November 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/10/'> October 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/09/'> September 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/08/'> August 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/07/'> July 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/06/'> June 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/05/'> May 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/04/'> April 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/03/'> March 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/02/'> February 2014 </option>
	<option value='https://www.tcdailyplanet.net/2014/01/'> January 2014 </option>
	<option value='https://www.tcdailyplanet.net/2013/12/'> December 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/11/'> November 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/10/'> October 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/09/'> September 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/08/'> August 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/07/'> July 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/06/'> June 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/05/'> May 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/04/'> April 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/03/'> March 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/02/'> February 2013 </option>
	<option value='https://www.tcdailyplanet.net/2013/01/'> January 2013 </option>
	<option value='https://www.tcdailyplanet.net/2012/12/'> December 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/11/'> November 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/10/'> October 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/09/'> September 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/08/'> August 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/07/'> July 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/06/'> June 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/05/'> May 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/04/'> April 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/03/'> March 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/02/'> February 2012 </option>
	<option value='https://www.tcdailyplanet.net/2012/01/'> January 2012 </option>
	<option value='https://www.tcdailyplanet.net/2011/12/'> December 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/11/'> November 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/10/'> October 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/09/'> September 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/08/'> August 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/07/'> July 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/06/'> June 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/05/'> May 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/04/'> April 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/03/'> March 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/02/'> February 2011 </option>
	<option value='https://www.tcdailyplanet.net/2011/01/'> January 2011 </option>
	<option value='https://www.tcdailyplanet.net/2010/12/'> December 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/11/'> November 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/10/'> October 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/09/'> September 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/08/'> August 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/07/'> July 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/06/'> June 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/05/'> May 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/04/'> April 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/03/'> March 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/02/'> February 2010 </option>
	<option value='https://www.tcdailyplanet.net/2010/01/'> January 2010 </option>
	<option value='https://www.tcdailyplanet.net/2009/12/'> December 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/11/'> November 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/10/'> October 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/09/'> September 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/08/'> August 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/07/'> July 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/06/'> June 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/05/'> May 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/04/'> April 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/03/'> March 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/02/'> February 2009 </option>
	<option value='https://www.tcdailyplanet.net/2009/01/'> January 2009 </option>
	<option value='https://www.tcdailyplanet.net/2008/12/'> December 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/11/'> November 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/10/'> October 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/09/'> September 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/08/'> August 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/07/'> July 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/06/'> June 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/05/'> May 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/04/'> April 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/03/'> March 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/02/'> February 2008 </option>
	<option value='https://www.tcdailyplanet.net/2008/01/'> January 2008 </option>
	<option value='https://www.tcdailyplanet.net/2007/12/'> December 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/11/'> November 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/10/'> October 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/09/'> September 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/08/'> August 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/07/'> July 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/06/'> June 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/05/'> May 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/04/'> April 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/03/'> March 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/02/'> February 2007 </option>
	<option value='https://www.tcdailyplanet.net/2007/01/'> January 2007 </option>
	<option value='https://www.tcdailyplanet.net/2006/12/'> December 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/11/'> November 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/10/'> October 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/09/'> September 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/08/'> August 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/07/'> July 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/06/'> June 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/05/'> May 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/04/'> April 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/03/'> March 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/02/'> February 2006 </option>
	<option value='https://www.tcdailyplanet.net/2006/01/'> January 2006 </option>
	<option value='https://www.tcdailyplanet.net/2005/12/'> December 2005 </option>
	<option value='https://www.tcdailyplanet.net/2005/11/'> November 2005 </option>
	<option value='https://www.tcdailyplanet.net/2005/10/'> October 2005 </option>
	<option value='https://www.tcdailyplanet.net/2005/09/'> September 2005 </option>
	<option value='https://www.tcdailyplanet.net/2000/10/'> October 2000 </option>

		</select>
		</div>	</div>

	</div>
<div id="boilerplate">
	<div class="row-fluid clearfix">
		<div class="span9">
			<ul id="footer-social" class="social-icons">
				<li><a href="https://www.tcdailyplanet.net/?feed=rss2" title="Link to RSS Feed"><i class="icon-rss"></i></a></li><li><a href="https://facebook.com/tcdailyplanet" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/tcdailyplanet" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li>			</ul>
		</div>

			</div>

	<div class="row-fluid clearfix">
		<div class="span9">
			<div class="footer-bottom clearfix">

				<!-- If you enjoy this theme and use it on a production site we would appreciate it if you would leave the credit in place. Thanks :) -->
				<p class="footer-credit">&copy; Copyright 2017, Twin Cities Enterprise</p>
				<p class="footer-credit">This site built with <a href="http://largoproject.org">Project Largo</a> from <a href="http://inn.org">INN</a> and proudly powered by <a href="http://wordpress.org" rel="nofollow">WordPress</a>.</p>
			</div>
		</div>
		<div class="span3">
					</div>
	</div>

	<div class="row-fluid clearfix">
		<div class="span12">
			<p class="back-to-top"><a href="#top">Back to top &uarr;</a></p>
					</div>
	</div>
</div>

	</footer>
</div>

		<script type="text/javascript">
		/*<![CDATA[*/
		var gmapstyles = 'default';
		/* ]]> */
		</script>		
				<script type="text/javascript">
			var LMP = {"ajax_url":"https:\/\/www.tcdailyplanet.net\/wp-admin\/admin-ajax.php","paged":0,"query":{"post__not_in":null,"page":"","ajde_events":"29th-annual-taste-of-greece-festival","post_type":"ajde_events","name":"29th-annual-taste-of-greece-festival"},"is_home":false,"is_series_landing":false};
		</script>
	

		
		<!--Facebook-->
		<div id="fb-root"></div>
		<script>(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script>

		
		
		<!--Twitter-->
		<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

		
	<div class='evo_lightboxes'>					<div class='evo_lightbox eventcard eventon_events_list' id=''>
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose '>X</a>
									<div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'></div>
								</div>
							</div>							
						</div>
					</div>
					</div><script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/comment-reply.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/www/wp-content/themes/tcdailyplanet-largo-child/js/your_theme.js?ver=0.1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/load-more-posts.js'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/largoCore.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/largoPlugins.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/themes/largo/js/jquery.idTabs.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/eventon_functions.js?ver=2.4.10'></script>
<script type='text/javascript' src='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/jquery.mobile.min.js?ver=2.4.10'></script>
<script type='text/javascript' src='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/jquery.mousewheel.min.js?ver=2.4.10'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var the_ajax_script = {"ajaxurl":"https:\/\/www.tcdailyplanet.net\/wp-admin\/admin-ajax.php","postnonce":"2cdb4aaa25"};
/* ]]> */
</script>
<script type='text/javascript' src='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/eventon_script.js?ver=2.4.10'></script>
<script type='text/javascript' src='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/jquery.easing.1.3.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/plugins/eventon-search/assets/script.js?ver=1'></script>
<script type='text/javascript' src='https://maps.googleapis.com/maps/api/js?ver=1.0'></script>
<script type='text/javascript' src='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/maps/eventon_gen_maps.js?ver=2.4.10'></script>
<script type='text/javascript' src='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/js/maps/eventon_init_gmap.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.tcdailyplanet.net/wp-content/plugins/akismet/_inc/form.js?ver=3.3.4'></script>

</body>
</html>
