<!DOCTYPE html>
<!--[if lt IE 7]> <html lang="en-US" class="no-js ie6"> <![endif]-->
<!--[if IE 7]>    <html lang="en-US" class="no-js ie7"> <![endif]-->
<!--[if IE 8]>    <html lang="en-US" class="no-js ie8"> <![endif]-->
<!--[if IE 9]>    <html lang="en-US" class="no-js ie9"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>
	<meta charset="UTF-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0">
	<title>
		MUSIC REVIEW | &#8220;Sesame Street Live: Let&#8217;s Dance!&#8221; gets warm and fuzzy at the State Theatre | Twin Cities Daily Planet	</title>
	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="http://www.tcdailyplanet.net/xmlrpc.php" />
		<script>
			function whichHeader() {
				var screenWidth = document.documentElement.clientWidth,
				header_img;
				if (screenWidth <= 767) {
					header_img = 'http://deep-silk.flywheelsites.com/wp-content/uploads/2014/06/DP-logo-without-5702-336x661-336x66.png';
				} else if (screenWidth > 767 && screenWidth <= 979) {
					header_img = 'http://deep-silk.flywheelsites.com/wp-content/uploads/2014/06/DP-logo-without-5702-336x662-336x66.png';
				} else {
					header_img = 'http://deep-silk.flywheelsites.com/wp-content/uploads/2014/06/DP-logo-without-5702-336x663-336x66.png';
				}
				return header_img;
			}
			var banner_img_src = whichHeader();
		</script>
	<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; Feed" href="http://www.tcdailyplanet.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; Comments Feed" href="http://www.tcdailyplanet.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Twin Cities Daily Planet &raquo; MUSIC REVIEW | &#8220;Sesame Street Live: Let&#8217;s Dance!&#8221; gets warm and fuzzy at the State Theatre Comments Feed" href="http://www.tcdailyplanet.net/music-review-sesame-street-live-lets-dance-state-theatre/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.tcdailyplanet.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='http://www.tcdailyplanet.net/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slides-css'  href='http://www.tcdailyplanet.net/wp-content/themes/largo/lib/navis-slideshows/css/slides.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slick-css'  href='http://www.tcdailyplanet.net/wp-content/themes/largo/lib/navis-slideshows/vendor/slick/slick.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='evo_sr_styles-css'  href='http://www.tcdailyplanet.net/wp-content/plugins/eventon-search/assets/styles.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='super-rss-reader-css-css'  href='http://www.tcdailyplanet.net/wp-content/plugins/super-rss-reader/public/srr-css.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='largo-stylesheet-css'  href='http://www.tcdailyplanet.net/?ver=4.7.2&#038;largo_custom_less_variable=1&#038;css_file=style.min.css&#038;timestamp=0' type='text/css' media='all' />
<link rel='stylesheet' id='largo-child-styles-css'  href='http://www.tcdailyplanet.net/wp-content/themes/tcdailyplanet-largo-child/style.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A400%2C400i%2C300&#038;ver=4.7.2' type='text/css' media='screen' />
<link rel='stylesheet' id='evcal_cal_default-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/css/eventon_styles.css?ver=2.4.10' type='text/css' media='all' />
<link rel='stylesheet' id='evo_font_icons-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/fonts/font-awesome.css?ver=2.4.10' type='text/css' media='all' />
<link rel='stylesheet' id='eventon_dynamic_styles-css'  href='//www.tcdailyplanet.net/wp-content/plugins/eventON/assets/css/eventon_dynamic_styles.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='yarpp-thumbnails-yarpp-thumbnail-css'  href='http://www.tcdailyplanet.net/wp-content/plugins/yet-another-related-posts-plugin/includes/styles_thumbnails.css.php?width=120&#038;height=120&#038;ver=4.4' type='text/css' media='all' />
<link rel='stylesheet' id='evo_fc_styles-css'  href='http://www.tcdailyplanet.net/wp-content/plugins/eventon-full-cal/assets/fc_styles.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='homepage-slider-css'  href='http://www.tcdailyplanet.net/wp-content/themes/largo/homepages/assets/css/top-stories.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='argo-links-css'  href='http://www.tcdailyplanet.net/wp-content/plugins/argo-links/css/argo-links.css?ver=1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.tcdailyplanet.net/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.tcdailyplanet.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.tcdailyplanet.net/wp-content/plugins/super-rss-reader/public/srr-js.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.tcdailyplanet.net/wp-content/themes/largo/js/modernizr.custom.js?ver=4.7.2'></script>
<link rel='https://api.w.org/' href='http://www.tcdailyplanet.net/wp-json/' />
<link rel='prev' title='3 MLK quotes that convict me today' href='http://www.tcdailyplanet.net/3-mlk-quotes-convict-me-today/' />
<link rel='next' title='THEATER PREVIEW | Minnesota Opera adds a potent kick in &#8220;The Elixir of Love&#8221;' href='http://www.tcdailyplanet.net/minnesota-opera-brews-it-kick-elixir-love/' />
<link rel="canonical" href="http://www.tcdailyplanet.net/music-review-sesame-street-live-lets-dance-state-theatre/" />
<link rel='shortlink' href='http://www.tcdailyplanet.net/?p=205443' />
<link rel="alternate" type="application/json+oembed" href="http://www.tcdailyplanet.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.tcdailyplanet.net%2Fmusic-review-sesame-street-live-lets-dance-state-theatre%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.tcdailyplanet.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.tcdailyplanet.net%2Fmusic-review-sesame-street-live-lets-dance-state-theatre%2F&#038;format=xml" />
<link rel="stylesheet" href="http://www.tcdailyplanet.net/wp-content/plugins/multi-column-taxonomy-list/css/multi-column-taxonomy-link.css" type="text/css" />
		<meta name="twitter:card" content="summary">

		<meta name="twitter:site" content="@tcdailyplanet">
		<meta name="twitter:creator" content="@gin026">					<meta property="og:title" content="MUSIC REVIEW | &#8220;Sesame Street Live: Let&#8217;s Dance!&#8221; gets warm and fuzzy at the State Theatre" />
					<meta property="og:type" content="article" />
					<meta property="og:url" content="http://www.tcdailyplanet.net/music-review-sesame-street-live-lets-dance-state-theatre/"/>
					<meta property="og:description" content="State Theatre in Minneapolis brought the childhood favorite neighborhood, 123 Sesame Street, to their venue last weekend for seven shows. Those in attendance were in for a treat as they sang and danced along with the locals of Sesame Street as the musical featured the crowd favorite characters Elmo, Big Bird, Ernie, Cookie Monster, Abby [&hellip;]" />
					<meta name="description" content="State Theatre in Minneapolis brought the childhood favorite neighborhood, 123 Sesame Street, to their venue last weekend for seven shows. Those in attendance were in for a treat as they sang and danced along with the locals of Sesame Street as the musical featured the crowd favorite characters Elmo, Big Bird, Ernie, Cookie Monster, Abby [&hellip;]" />
			<meta property="og:site_name" content="Twin Cities Daily Planet" /><meta property="og:image" content="http://www.tcdailyplanet.net/wp-content/uploads/files/15/19/472_itsybitzyspider1_hr.jpg" /><link rel="shortcut icon" href="http://deep-silk.flywheelsites.com/wp-content/uploads/2014/06/tcdp_inside_favicon1.ico"/><meta name="news_keywords" content="Article, Arts + Culture, Daily Planet Originals, Entertainment, Music, CC area"><meta name="original-source" content="http://www.tcdailyplanet.net/music-review-sesame-street-live-lets-dance-state-theatre/" /><meta name="syndication-source" content="http://www.tcdailyplanet.net/music-review-sesame-street-live-lets-dance-state-theatre/" />			<script>
			    var _gaq = _gaq || [];
							_gaq.push(['_setAccount', 'UA-1003974-1']);
				_gaq.push(['_trackPageview']);
										    _gaq.push(
					["largo._setAccount", "UA-17578670-4"],
					["largo._setCustomVar", 1, "SiteName", "Twin Cities Daily Planet"],
					["largo._setDomainName", "www.tcdailyplanet.net"],
					["largo._setAllowLinker", true],
					["largo._trackPageview"]
				);

			    (function() {
				    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
				    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
				    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
	

<!-- EventON Version -->
<meta name="generator" content="EventON 2.4.10" />

	<!-- Include google_services.js -->
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/1000577/tcdp-leaderboard-728x90-wp', [728,90], "acm-ad-tag-tcdp-leaderboard-728x90-wp").addService(googletag.pubads());
googletag.defineSlot('/1000577/tcdp-sbmain-wp-01', [300,250], "acm-ad-tag-tcdp-sbmain-wp-01").addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>
</head>

<body class="post-template-default single single-post postid-205443 single-format-standard classic">

	<div id="top"></div>

	
		<div class="global-nav-bg">
		<div class="global-nav">
			<nav id="top-nav" class="span12">
				<span class="visuallyhidden">
					<a href="#main" title="Skip to content">Skip to content</a>
				</span>
				<ul id="menu-global-navigation" class="menu"><li id="menu-item-208085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208085"><a href="http://www.tcdailyplanet.net/advertise/">Advertise</a></li>
<li id="menu-item-208086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208086"><a href="http://www.tcdailyplanet.net/contact-us/">Contact us</a></li>
<li id="menu-item-208087" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208087"><a href="http://www.tcdailyplanet.net/subscribe-newsletters/">Subscribe to Newsletters</a></li>
<li id="menu-item-208088" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208088"><a href="http://www.tcdailyplanet.net/donors-sponsors/">Donors and Sponsors</a></li>
</ul>				<div class="nav-right">
											<ul id="header-social" class="social-icons visible-desktop">
							<li><a href="http://deep-silk.flywheelsites.com/?feed=rss2" title="Link to RSS Feed"><i class="icon-rss"></i></a></li><li><a href="https:/facebook.com/tcdailyplanet" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/tcdailyplanet" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li>						</ul>
					<div class="donate-btn"><a href="http://tcdailyplanet.net/donate"><i class="icon-heart"></i>Donate Now</a></div> 
					<div id="header-search">
						<form class="form-search" role="search" method="get" action="http://www.tcdailyplanet.net/">
							<div class="input-append">
								<input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" /><button type="submit" class="search-submit btn">Go</button>
							</div>
						</form>
					</div>

				</div>
			</nav>
		</div> <!-- /.global-nav -->
	</div> <!-- /.global-nav-bg -->

	<div id="page" class="hfeed clearfix">

		
		<!---<div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
-->

		
<header id="site-header" class="clearfix dp-header-test branding" itemscope itemtype="http://schema.org/Organization">
<div class="row-fluid clearfix">
		<div class="span4 dp-header-test hidden-phone"><h2 class="visuallyhidden"><a itemprop="url" href="http://www.tcdailyplanet.net/"><span itemprop="name">Twin Cities Daily Planet</span> - <span class="tagline" itemprop="description">Amplifying and connecting marginalized voices</span></a></h2><a itemprop="url" href="http://www.tcdailyplanet.net/"><img class="header_img" src="" alt="" /></a></div>
		<div class="span8 dp-header-test hidden-phone" ><div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
</div>
	</div>
	<div class="row-fluid clearfix">
		<div class="span12 dp-header-test visible-phone"><h2 class="visuallyhidden"><a itemprop="url" href="http://www.tcdailyplanet.net/"><span itemprop="name">Twin Cities Daily Planet</span> - <span class="tagline" itemprop="description">Amplifying and connecting marginalized voices</span></a></h2><a itemprop="url" href="http://www.tcdailyplanet.net/"><img class="header_img" src="" alt="" /></a></div>
	</div>
	<div class="row-fluid clearfix">
		<!--<div class="span12 dp-header-test visible-phone" ><div class="header-ad-zone max-wide">
	<div id="header-ad-zone-container">
		<aside id="acm_ad_zones-14" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-leaderboard-728x90-wp' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-leaderboard-728x90-wp'); });
</script>
		</div>
		</aside>	</div>
</div>
</div>-->
	</div>
	

			

		
</header>
<header class="print-header">
	<p><strong>Twin Cities Daily Planet</strong> (http://www.tcdailyplanet.net/music-review-sesame-street-live-lets-dance-state-theatre/)</p>
</header>


		<nav id="main-nav" class="navbar clearfix">
	<div class="navbar-inner">
		<div class="container">
			<!-- .btn-navbar is used as the toggle for collapsed navbar content -->
			<a class="btn btn-navbar toggle-nav-bar"  title="More">
				<div class="bars">
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
					<span class="icon-bar"></span>
				</div>
			</a>

			<div class="nav-shelf">
				<ul class="nav">
					<li id="menu-item-208065" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-208065"><a href="http://deep-silk.flywheelsites.com/">Home</a></li>
<li id="menu-item-638045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-638045"><a href="http://www.tcdailyplanet.net/about-2/">About</a></li>
<li id="menu-item-208096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-208096"><a href="http://www.tcdailyplanet.net/category/news/">News + Features</a></li>
<li id="menu-item-307496" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-307496"><a href="http://www.tcdailyplanet.net/category/arts/">Arts + Culture</a></li>
<li id="menu-item-208098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-208098"><a href="http://www.tcdailyplanet.net/category/community-voices/">Community Voices</a></li>
<li id="menu-item-379992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-379992"><a href="http://www.tcdailyplanet.net/category/blogs/">Blogs</a></li>
<li id="menu-item-208066" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-208066"><a href="#" class="dropdown-toggle">Partners <b class="caret"></b></a></a>
<ul class="dropdown-menu">
	<li id="menu-item-208067" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208067"><a href="http://www.tcdailyplanet.net/partner_type/contributing-blogs/">Contributing Blogs</a></li>
	<li id="menu-item-208068" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208068"><a href="http://www.tcdailyplanet.net/partner_type/community-media/">Community Media</a></li>
	<li id="menu-item-208069" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208069"><a href="http://www.tcdailyplanet.net/partner_type/arts-media/">Arts Media</a></li>
	<li id="menu-item-208070" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208070"><a href="http://www.tcdailyplanet.net/partner_type/ethnic-media/">Ethnic Media</a></li>
	<li id="menu-item-208071" class="menu-item menu-item-type-taxonomy menu-item-object-partner_type menu-item-208071"><a href="http://www.tcdailyplanet.net/partner_type/neighborhood-associations/">Neighborhood Associations</a></li>
</ul>
</li>
<li id="menu-item-675422" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-675422"><a href="http://www.tcdailyplanet.net/event-directory/">Events</a></li>
<li id="menu-item-675423" class="menu-item menu-item-type-taxonomy menu-item-object-event_type menu-item-675423"><a href="http://www.tcdailyplanet.net/event-type/classes/">Classes</a></li>
<li id="menu-item-617426" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-617426"><a href="http://www.tcdailyplanet.net/work-with-us/">Work with Us</a></li>
				</ul>

				<ul class="nav visible-phone">
										<li class="menu-item-has-childen dropdown">
						<a href="javascript:void(0);" class="dropdown-toggle">Global Navigation <b class="caret"></b>
						</a>
						<ul id="menu-global-navigation-1" class="dropdown-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208085"><a href="http://www.tcdailyplanet.net/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208086"><a href="http://www.tcdailyplanet.net/contact-us/">Contact us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208087"><a href="http://www.tcdailyplanet.net/subscribe-newsletters/">Subscribe to Newsletters</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208088"><a href="http://www.tcdailyplanet.net/donors-sponsors/">Donors and Sponsors</a></li>
</ul>					</li>
									</ul>
			</div>
		</div>
	</div>
</nav>
<nav id="secondary-nav" class="clearfix">
	<div id="topics-bar" class="span12 hidden-phone">
		<ul id="menu-dont-miss" class="menu"><li class="menu-label"></li></ul>	</div>
</nav>


		
		
		<div id="main" class="row-fluid clearfix">

		
<div id="content" class="span8" role="main">

	
<article id="post-205443" class="hnews item post-205443 post type-post status-publish format-standard has-post-thumbnail hentry category-article category-arts category-daily-planet-originals category-entertainment category-music tag-cc-area" itemscope itemtype="http://schema.org/Article">

	
	<header>

 		<h1 class="entry-title" itemprop="headline">MUSIC REVIEW | &#8220;Sesame Street Live: Let&#8217;s Dance!&#8221; gets warm and fuzzy at the State Theatre</h1>
 		<h5 class="byline"><span class="by-author"><span class="by">By</span> <span class="author vcard" itemprop="author">Gino Terrell (<a href="http://www.tcdailyplanet.net/originals">TC Daily Planet</a>)</span></span><span class="sep"> | </span><time class="entry-date updated dtstamp pubdate" datetime="2015-01-19T18:35:16+00:00">January 19, 2015</time></h5>

 		<div class="post-social clearfix"><div class="left"><span class="twitter"><a href="http://twitter.com/share" class="twitter-share-button" data-url="http://www.tcdailyplanet.net/music-review-sesame-street-live-lets-dance-state-theatre/" data-text="MUSIC REVIEW | &#8220;Sesame Street Live: Let&#8217;s Dance!&#8221; gets warm and fuzzy at the State Theatre" data-via="tcdailyplanet" data-via="gin026:Follow the author of this article" data-count="none">Tweet</a></span><span class="facebook"><fb:like href="http://www.tcdailyplanet.net/music-review-sesame-street-live-lets-dance-state-theatre/" send="false" layout="button_count" show_faces="false" action="like"></fb:like></span></div><div class="right"><span class="print"><a href="#" onclick="window.print()" title="Print this article" rel="nofollow"><i class="icon-print"></i> Print</a></span><span data-service="email" class="email custom-share-button icon-mail share-button"> Email</span></div></div>
 		<meta itemprop="description" content="State Theatre in Minneapolis brought the childhood favorite neighborhood, 123 Sesame Street, to their venue last weekend for seven shows.Those in attendance were in for a treat as they sang and danced along with the locals of Sesame Street as the musical featured the crowd favorite characters Elmo, Big Bird, Ernie, Cookie Monster, Abby Cadabby, Bert and many more.VEE Corporation’s Sesame Street Live: Let’s Dance!&nbsp;opened their weekend performance on Friday, Jan. 16. The show was hosted by two live performers. The show’s unique interactive performance got the crowd out of their seat and brought a smile out of the children as the characters roamed around the audience during the dance parties. Cookie Monster even posed for a photo and gave one little girl a hug.The dynamic and hip hosts Jordan (played by Rasheem Ford) and Riley (played by Kayleigh Shuler) introduced the audience to the locals on Sesame Street and taught the audience new dance moves and had them sing along to their hip-hop tinged covers to songs like “The Itsy Bitsy Spider” and “Wheels on the Bus Go Round and Round.”Along with their fresh dance moves they had Elmo present his favorite moves. 

Related stories:
No related posts.

" />
<meta itemprop="datePublished" content="2015-01-19T18:35:16+00:00" />
<meta itemprop="dateModified" content="2015-01-19T18:51:12+00:00" />
<meta itemprop="image" content="http://www.tcdailyplanet.net/wp-content/uploads/files/15/19/472_itsybitzyspider1_hr.jpg" />
	</header><!-- / entry header -->

			<div class="hero  is-image">
		<div class="dp-featured-image-container"><div class="dp-featured-image clearfix"><img width="300" height="300" src="http://www.tcdailyplanet.net/wp-content/uploads/files/15/19/472_itsybitzyspider1_hr.jpg" class="attachment-full size-full wp-post-image" alt="" /><div class="dp-caption"><p>Photo credit TM/©Sesame Workshop</p></div></div>	</div>
	
	<div class="entry-content clearfix" itemprop="articleBody">
		<p>State Theatre in Minneapolis brought the childhood favorite neighborhood, 123 Sesame Street, to their venue last weekend for seven shows.<!--break--></p>
<p>Those in attendance were in for a treat as they sang and danced along with the locals of Sesame Street as the musical featured the crowd favorite characters Elmo, Big Bird, Ernie, Cookie Monster, Abby Cadabby, Bert and many more.</p>
<p>VEE Corporation’s <em><a href="http://sesamestreetlive.com/shows/lets-dance" target="_blank">Sesame Street Live: Let’s Dance!</a></em>&nbsp;opened their weekend performance on Friday, Jan. 16. The show was hosted by two live performers. The show’s unique interactive performance got the crowd out of their seat and brought a smile out of the children as the characters roamed around the audience during the dance parties. Cookie Monster even posed for a photo and gave one little girl a hug.</p>
<p>The dynamic and hip hosts Jordan (played by Rasheem Ford) and Riley (played by Kayleigh Shuler) introduced the audience to the locals on Sesame Street and taught the audience new dance moves and had them sing along to their hip-hop tinged covers to songs like “The Itsy Bitsy Spider” and “Wheels on the Bus Go Round and Round.”</p>
<p>Along with their fresh dance moves they had Elmo present his favorite moves. Elmo revealed it was the Robot. With the lightening switching to night blue and rotating disco lights, Elmo performed the Robot with three other Robot Muppets to demonstrate it to the crowd.</p>
<p>Later, Bert revealed his fear of dancing which is where the plot of this story kicks in. The community in Sesame Street rallied to help Bert overcome his fear and get out of his shell. By the end of the show, Bert transformed into a dancing machine. Baby Bear said dancing helped Bert overcome his shyness, allowed him to be himself and changed his attitude.</p>
<p>“Dancing really is a great way to show who you are,” Cadabby said.</p>
<p>Cookie Monster also got the crowd involved when he performed his rap. When he said “cookies” the crowd yelled “milk” and when he said “chocolate” the crowd screamed “chip.”</p>
<p>This show isn’t just for children to see their childhood heroes as parents can relate to the universal message Sesame Street is teaching through their story. The show demonstrates how collaboration can help one overcome fears and the most important thing, whether it’s through your creative expression or personality, is for one to always be true to themselves.</p>
<p>“The best kind of dance is to just be yourself,” Cookie Monster said.</p>
<p>The show literally ends with a bang as they shoot confetti over the audience after performing the final song.</p>
<p>Overall, a great show for parents to introduce their children to their favorite heroes and heroines, as well as take away lessons from the play like teamwork, adapting a positive attitude and staying true to one’s self.</p>
<hr>
<p><em>Coverage of issues and events that affect Central Corridor neighborhoods and communities is funded in part by a grant from Central Corridor Funders Collaborative.</em></p>
<div class='yarpp-related yarpp-related-none'>
<h3>Related stories:</h3>
<p>No related posts.</p>
</div>
	</div><!-- .entry-content -->

	
	<footer class="post-meta bottom-meta">

    
	</footer><!-- /.post-meta -->

	
</article><!-- #post-205443 -->
	<div id="comments" class="clearfix">
	
	
			<h2 id="comments-title">
			4 thoughts on &ldquo;<span>MUSIC REVIEW | &#8220;Sesame Street Live: Let&#8217;s Dance!&#8221; gets warm and fuzzy at the State Theatre</span>&rdquo;		</h2>

		
		<ol class="commentlist">
					<li class="post pingback">
			<p>Pingback: <a href='https://gterrell01.wordpress.com/2017/02/01/kayleigh-shuler-plays-lead-in-after-oil/' rel='external nofollow' class='url'>Kayleigh Shuler plays lead in After Oil | Hidden Valley Culture News</a></p>
		</li><!-- #comment-## -->
		<li class="post pingback">
			<p>Pingback: <a href='https://gterrell01.wordpress.com/2017/02/01/acting-out-his-passion-on-stage-rasheem-ford-to-star-in-dreamgirls/' rel='external nofollow' class='url'>Acting out his passion on stage, Rasheem Ford to star in Dreamgirls | Hidden Valley Culture News</a></p>
		</li><!-- #comment-## -->
		<li class="post pingback">
			<p>Pingback: <a href='https://hiddenvalleyculturecom.wordpress.com/2017/02/01/kayleigh-shuler-plays-lead-in-after-oil/' rel='external nofollow' class='url'>Kayleigh Shuler plays lead in After Oil &#8211; Hidden Valley Culture</a></p>
		</li><!-- #comment-## -->
		<li class="post pingback">
			<p>Pingback: <a href='https://hiddenvalleyculturecom.wordpress.com/2017/02/01/acting-out-his-passion-on-stage-rasheem-ford-to-star-in-dreamgirls/' rel='external nofollow' class='url'>Acting out his passion on stage, Rasheem Ford to star in Dreamgirls &#8211; Hidden Valley Culture</a></p>
		</li><!-- #comment-## -->
		</ol>

		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/music-review-sesame-street-live-lets-dance-state-theatre/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://www.tcdailyplanet.net/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='205443' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5f4f548edd" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="20"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->
</div>


<aside id="sidebar" class="span4">
		<div class="widget-area " role="complementary">
		<aside id="acm_ad_zones-10" class="widget widget-1 odd default acm_ad_zones clearfix">
		<div id='acm-ad-tag-tcdp-sbmain-wp-01' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('acm-ad-tag-tcdp-sbmain-wp-01'); });
</script>
		</div>
		</aside><aside id="text-6" class="widget widget-2 even default widget_text clearfix"><h3 class="widgettitle">Submit an event</h3>			<div class="textwidget">Please complete the  <a href="http://www.tcdailyplanet.net/event-submission/">form here</a> to submit an event to our calendar.</div>
		</aside><aside id="text-4" class="widget widget-3 odd default widget_text clearfix"><h3 class="widgettitle">Tweets from TC Daily Planet</h3>			<div class="textwidget"><a class="twitter-timeline" href="https://twitter.com/tcdailyplanet" data-widget-id="548900467502096384">Tweets by @tcdailyplanet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div>
		</aside><aside id="largo-featured-widget-5" class="widget widget-4 even default largo-featured clearfix"><h3 class="widgettitle">Today&#8217;s top stories</h3>			<div class="post-lead clearfix">
			<img width="60" height="60" src="http://www.tcdailyplanet.net/wp-content/uploads/2016/05/IMG_0267-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="Glendale" srcset="http://www.tcdailyplanet.net/wp-content/uploads/2016/05/IMG_0267-60x60.jpg 60w, http://www.tcdailyplanet.net/wp-content/uploads/2016/05/IMG_0267-140x140.jpg 140w, http://www.tcdailyplanet.net/wp-content/uploads/2016/05/IMG_0267-32x32.jpg 32w, http://www.tcdailyplanet.net/wp-content/uploads/2016/05/IMG_0267-50x50.jpg 50w, http://www.tcdailyplanet.net/wp-content/uploads/2016/05/IMG_0267-64x64.jpg 64w, http://www.tcdailyplanet.net/wp-content/uploads/2016/05/IMG_0267-96x96.jpg 96w, http://www.tcdailyplanet.net/wp-content/uploads/2016/05/IMG_0267-128x128.jpg 128w" sizes="(max-width: 60px) 100vw, 60px" />			<h5><a href="http://www.tcdailyplanet.net/community-voices-one-womans-displacement-in-richfield-forebodes-similar-fate-for-minneapolis-public-housing-residents/">Community Voices: One woman&#8217;s displacement in Richfield forebodes similar fate for Minneapolis Public Housing residents</a></h5>
						<p>This commentary is in response to the article by the Star Tribune regarding the new executive director of Minneapolis Public Housing Authority, (MPHA) Gregory P. Russ. </p>				</div> <!-- /.post-lead -->
					<div class="post-lead clearfix">
			<img width="60" height="60" src="http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-60x60.jpg 60w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-140x140.jpg 140w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-32x32.jpg 32w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-50x50.jpg 50w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-64x64.jpg 64w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-96x96.jpg 96w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-128x128.jpg 128w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-120x120.jpg 120w" sizes="(max-width: 60px) 100vw, 60px" />			<h5><a href="http://www.tcdailyplanet.net/singer-songwriter-mayyadda-explores-new-sound-and-shows-black-musicians-are-not-a-monolith/">Singer-songwriter Mayyadda explores new sound and shows Black musicians ‘are not a monolith’</a></h5>
						<p>Two years ago, if you had told Mayyadda Munkunjae that she would be performing at Minneapolis’ Dakota Jazz Club, where the likes of Prince, Esperanza Spalding and Vusi Mahlesela have graced the stage, she would probably have scoffed. </p>				</div> <!-- /.post-lead -->
					<div class="post-lead clearfix">
			<img width="60" height="60" src="http://www.tcdailyplanet.net/wp-content/uploads/2017/01/2017CEPClass640-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="http://www.tcdailyplanet.net/wp-content/uploads/2017/01/2017CEPClass640-60x60.jpg 60w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/2017CEPClass640-140x140.jpg 140w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/2017CEPClass640-390x384.jpg 390w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/2017CEPClass640-32x32.jpg 32w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/2017CEPClass640-50x50.jpg 50w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/2017CEPClass640-64x64.jpg 64w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/2017CEPClass640-96x96.jpg 96w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/2017CEPClass640-128x128.jpg 128w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/2017CEPClass640-120x120.jpg 120w" sizes="(max-width: 60px) 100vw, 60px" />			<h5><a href="http://www.tcdailyplanet.net/best-of-neighborhood-news-126-building-a-pipeline-for-diverse-policy-leaders-in-st-paul/">Best of Neighborhood News 1/26: Building a pipeline for diverse policy leaders in St. Paul</a></h5>
						<p>Ibrihim Hirsi for MinnPost highlighted a new program at Wilder Foundation called Community Equity Pipeline (CEP), where 14 nonprofit professionals – mostly people of color – will gain intensive training on policy to "change the status quo" of Minnesota's leadership. </p>				</div> <!-- /.post-lead -->
				
		</aside><aside id="largo-explore-related-widget-2" class="widget widget-5 odd default largo-explore-related clearfix">
			<div id="related-posts" class="idTabs row-fluid clearfix">
				<ul id="related-post-nav" class="span4">
					<li><h5>In case you missed it</h5></li>
					<li><a href="#rp0">Article</a></li><li><a href="#rp1">Arts + Culture</a></li><li><a href="#rp2">Daily Planet Originals</a></li><li><a href="#rp3">Entertainment</a></li><li><a href="#rp4">Music</a></li><li><a href="#rp5">CC area</a></li>				</ul>

				<div class="related-items span8">
											<div id="rp0">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="http://www.tcdailyplanet.net/so-long-open-streets-its-been-fun/" title="Read So long Open Streets. It&#039;s been fun!">So long Open Streets. It&#039;s been fun!</a></h3><a href="http://www.tcdailyplanet.net/so-long-open-streets-its-been-fun/"/><img width="60" height="60" src="http://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="http://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-60x60.jpg 60w, http://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-140x140.jpg 140w, http://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-32x32.jpg 32w, http://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-64x64.jpg 64w, http://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-96x96.jpg 96w, http://www.tcdailyplanet.net/wp-content/uploads/2015/09/big-family-128x128.jpg 128w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>Lowry Avenue in North Minneapolis hosted the season's last Open Streets event. Photographer Mark Peterson was there to catch all the action. </p>								</li>
								<li><a href="http://www.tcdailyplanet.net/viva-mexico-minneapolis-celebrates-mexican-independence-day/" title="Article">Viva Mexico! Minneapolis celebrates Mexican Independence Day</a></li><li><a href="http://www.tcdailyplanet.net/sugarush-donuts-light-rail-green-line/" title="Article">A doughnut shop owner looks to the future on (or near) the light rail</a></li>							</ul>

							<p><a href="http://www.tcdailyplanet.net/category/article/" title="Article" target="_blank"><strong>View all Article Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
											<div id="rp1">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="http://www.tcdailyplanet.net/singer-songwriter-mayyadda-explores-new-sound-and-shows-black-musicians-are-not-a-monolith/" title="Read Singer-songwriter Mayyadda explores new sound and shows Black musicians ‘are not a monolith’">Singer-songwriter Mayyadda explores new sound and shows Black musicians ‘are not a monolith’</a></h3><a href="http://www.tcdailyplanet.net/singer-songwriter-mayyadda-explores-new-sound-and-shows-black-musicians-are-not-a-monolith/"/><img width="60" height="60" src="http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-60x60.jpg 60w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-140x140.jpg 140w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-32x32.jpg 32w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-50x50.jpg 50w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-64x64.jpg 64w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-96x96.jpg 96w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-128x128.jpg 128w, http://www.tcdailyplanet.net/wp-content/uploads/2017/01/Mayyadda-39-120x120.jpg 120w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>Two years ago, if you had told Mayyadda Munkunjae that she would be performing at Minneapolis’ Dakota Jazz Club, where the likes of Prince, Esperanza Spalding and Vusi Mahlesela have graced the stage, she would probably have scoffed.</p>								</li>
								<li><a href="http://www.tcdailyplanet.net/two-minneapolis-tattoo-parlors-drop-industrys-toxic-masculinity-in-favor-gender-lgbtqia-inclusivity/" title="Arts + Culture">Two Minneapolis tattoo parlors drop industry’s toxic masculinity in favor of gender, LGBTQIA inclusivity</a></li><li><a href="http://www.tcdailyplanet.net/artist-chamindika-wanduragala-takes-on-motherhood-and-race-through-puppets/" title="Arts + Culture">Artist Chamindika Wanduragala takes on motherhood and race through puppets</a></li>							</ul>

							<p><a href="http://www.tcdailyplanet.net/category/arts/" title="Arts + Culture" target="_blank"><strong>View all Arts + Culture Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
											<div id="rp2">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="http://www.tcdailyplanet.net/minnesota-is-no-utopia-for-workers-labor-day-and-the-fight-for-15-an-hour/" title="Read Minnesota is no utopia for workers: Labor Day and the fight for $15 an hour">Minnesota is no utopia for workers: Labor Day and the fight for $15 an hour</a></h3><a href="http://www.tcdailyplanet.net/minnesota-is-no-utopia-for-workers-labor-day-and-the-fight-for-15-an-hour/"/><img width="60" height="60" src="http://www.tcdailyplanet.net/wp-content/uploads/2015/09/IMG_1330-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="http://www.tcdailyplanet.net/wp-content/uploads/2015/09/IMG_1330-60x60.jpg 60w, http://www.tcdailyplanet.net/wp-content/uploads/2015/09/IMG_1330-140x140.jpg 140w, http://www.tcdailyplanet.net/wp-content/uploads/2015/09/IMG_1330-32x32.jpg 32w, http://www.tcdailyplanet.net/wp-content/uploads/2015/09/IMG_1330-64x64.jpg 64w, http://www.tcdailyplanet.net/wp-content/uploads/2015/09/IMG_1330-96x96.jpg 96w, http://www.tcdailyplanet.net/wp-content/uploads/2015/09/IMG_1330-128x128.jpg 128w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>All photos by Kayla Steinberg

Although it was mainly a plot to cool out radical activism, Labor Day is widely remembered as a celebration of the successful fight for the eight-hour day. Yet, while we’re approaching the United States’ 121st official Labor Day, it is now impossible for low-wage Minnesota workers to support their families while working only eight hours a day. </p>								</li>
								<li><a href="http://www.tcdailyplanet.net/still-no-clues-on-the-west-broadway-fire/" title="Daily Planet Originals">Still no clues on the West Broadway fire</a></li><li><a href="http://www.tcdailyplanet.net/franklin-open-streets-showcases-a-slice-of-life-on-the-ave/" title="Daily Planet Originals">Franklin Open Streets showcases a slice of life on the  Ave</a></li>							</ul>

							<p><a href="http://www.tcdailyplanet.net/category/daily-planet-originals/" title="Daily Planet Originals" target="_blank"><strong>View all Daily Planet Originals Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
											<div id="rp3">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="http://www.tcdailyplanet.net/twin-cities-opera-renaissance-summer-edition/" title="Read The Twin Cities Opera Renaissance – Summer Edition">The Twin Cities Opera Renaissance – Summer Edition</a></h3><a href="http://www.tcdailyplanet.net/twin-cities-opera-renaissance-summer-edition/"/><img width="60" height="60" src="http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-60x60.jpg 60w, http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-140x140.jpg 140w, http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-32x32.jpg 32w, http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-64x64.jpg 64w, http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-96x96.jpg 96w, http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-128x128.jpg 128w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>On June 21, 1985, the Metropolitan Opera announced that it was ending more than a century of national tours. Not quite one year later, on May 31, 1986, the very last tour closed its doors with a farewell performance in Minneapolis’s Northrop Auditorium. </p>								</li>
								<li><a href="http://www.tcdailyplanet.net/theater-review-mr-rogers-neighborhood-thatswhatshesaid-take-brain-places-werent-expecting-go/" title="Entertainment">Mr. Rogers' Neighborhood and That'swhatshesaid takes your brain to places you weren't expecting to go</a></li><li><a href="http://www.tcdailyplanet.net/2015-little-mekong-night-market-in-photos/" title="Entertainment">2015 Little Mekong Night Market in photos</a></li>							</ul>

							<p><a href="http://www.tcdailyplanet.net/category/entertainment/" title="Entertainment" target="_blank"><strong>View all Entertainment Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
											<div id="rp4">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="http://www.tcdailyplanet.net/twin-cities-opera-renaissance-summer-edition/" title="Read The Twin Cities Opera Renaissance – Summer Edition">The Twin Cities Opera Renaissance – Summer Edition</a></h3><a href="http://www.tcdailyplanet.net/twin-cities-opera-renaissance-summer-edition/"/><img width="60" height="60" src="http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-60x60.jpg 60w, http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-140x140.jpg 140w, http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-32x32.jpg 32w, http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-64x64.jpg 64w, http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-96x96.jpg 96w, http://www.tcdailyplanet.net/wp-content/uploads/2015/08/2015-07-08-05.46.44-2-128x128.jpg 128w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>On June 21, 1985, the Metropolitan Opera announced that it was ending more than a century of national tours. Not quite one year later, on May 31, 1986, the very last tour closed its doors with a farewell performance in Minneapolis’s Northrop Auditorium. </p>								</li>
								<li><a href="http://www.tcdailyplanet.net/pirates-of-penzance-is-still-a-glorious-thing-in-its-135th-year/" title="Music">Pirates of Penzance is still a “Glorious Thing” in its 135th year</a></li><li><a href="http://www.tcdailyplanet.net/outdoor-hmong-music-at-the-history-center/" title="Music">Outdoor Hmong Music at the History Center</a></li>							</ul>

							<p><a href="http://www.tcdailyplanet.net/category/music/" title="Music" target="_blank"><strong>View all Music Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
											<div id="rp5">
							<ul>
							
								<li class="top-related clearfix">
								<h3><a href="http://www.tcdailyplanet.net/music-review-mary-chapin-carpenter-sings-her-stories-at-state-theatre/" title="Read MUSIC REVIEW | Mary Chapin Carpenter sings her stories at State Theatre">MUSIC REVIEW | Mary Chapin Carpenter sings her stories at State Theatre</a></h3><a href="http://www.tcdailyplanet.net/music-review-mary-chapin-carpenter-sings-her-stories-at-state-theatre/"/><img width="60" height="60" src="http://www.tcdailyplanet.net/wp-content/uploads/2015/05/APPROVEDMary_Chapin_Shot_C_0486_B_Final-60x60.jpg" class="attachment-60x60 size-60x60 wp-post-image" alt="" srcset="http://www.tcdailyplanet.net/wp-content/uploads/2015/05/APPROVEDMary_Chapin_Shot_C_0486_B_Final-60x60.jpg 60w, http://www.tcdailyplanet.net/wp-content/uploads/2015/05/APPROVEDMary_Chapin_Shot_C_0486_B_Final-140x140.jpg 140w, http://www.tcdailyplanet.net/wp-content/uploads/2015/05/APPROVEDMary_Chapin_Shot_C_0486_B_Final-50x50.jpg 50w, http://www.tcdailyplanet.net/wp-content/uploads/2015/05/APPROVEDMary_Chapin_Shot_C_0486_B_Final-32x32.jpg 32w, http://www.tcdailyplanet.net/wp-content/uploads/2015/05/APPROVEDMary_Chapin_Shot_C_0486_B_Final-64x64.jpg 64w, http://www.tcdailyplanet.net/wp-content/uploads/2015/05/APPROVEDMary_Chapin_Shot_C_0486_B_Final-96x96.jpg 96w, http://www.tcdailyplanet.net/wp-content/uploads/2015/05/APPROVEDMary_Chapin_Shot_C_0486_B_Final-128x128.jpg 128w" sizes="(max-width: 60px) 100vw, 60px" /></a><p>Mary Chapin Carpenter, the five-time Grammy Award-winning singer-songwriter with a 13-album catalog, returned to Minneapolis to play sans mosquitoes (her last Minnesota performance was at the MN Zoo Amphitheatre) at the Hennepin Theatre Trust’s State Theatre on May 2. It was an acoustic performance featuring her long-time friends and extraordinary musicians, John Carroll on keyboards and John Doyle on guitars and bouzouki. </p>								</li>
								<li><a href="http://www.tcdailyplanet.net/theater-review-jersey-boys-shines-at-the-orpheum-theatre/" title="CC area">THEATER REVIEW | "Jersey Boys" shines at the Orpheum Theatre</a></li><li><a href="http://www.tcdailyplanet.net/information-society-fine-line-music-cafe/" title="CC area">MUSIC REVIEW | Information Society at The Fine line Music Cafe</a></li>							</ul>

							<p><a href="http://www.tcdailyplanet.net/tag/cc-area/" title="CC area" target="_blank"><strong>View all CC area Posts &rarr;</strong></a></p>
						</div> <!-- /#rpX -->
									</div> <!-- /.items -->
			</div> <!-- /#related-posts -->
		</aside>	</div>
	</aside>

	</div> <!-- #main -->

</div><!-- #page -->


<div class="footer-bg clearfix">
	<footer id="site-footer">

		<div id="supplementary" class="row-fluid">
	
	<div class="span4 widget-area" role="complementary">
		<ul id="menu-footer-navigation" class="menu"><li class="menu-label"></li><li id="menu-item-307252" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-307252"><a href="http://www.tcdailyplanet.net/67262-2/">20/20 Tips for Community Journalists</a></li>
</ul>	</div>

	<div class="span4 widget-area" role="complementary">
		<aside id="text-7" class="widget widget-1 odd default widget_text clearfix">			<div class="textwidget"></div>
		</aside>	</div>

	<div class="span4 widget-area" role="complementary">
		<div class="widget widget_search"><h2 class="widgettitle">Search This Site</h2>
	<form class="form-search" role="search" method="get" action="http://www.tcdailyplanet.net/">
		<div>
			<input type="text" placeholder="Search" class="searchbox search-query" value="" name="s" />
			<input type="submit" value="Go" name="search submit" class="search-submit btn">
		</div>
	</form>

</div><div class="widget widget_archive"><h2 class="widgettitle">Browse Archives</h2>		<label class="screen-reader-text" for="archives-dropdown--1">Browse Archives</label>
		<select id="archives-dropdown--1" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='http://www.tcdailyplanet.net/2017/01/'> January 2017 </option>
	<option value='http://www.tcdailyplanet.net/2016/12/'> December 2016 </option>
	<option value='http://www.tcdailyplanet.net/2016/11/'> November 2016 </option>
	<option value='http://www.tcdailyplanet.net/2016/10/'> October 2016 </option>
	<option value='http://www.tcdailyplanet.net/2016/09/'> September 2016 </option>
	<option value='http://www.tcdailyplanet.net/2016/08/'> August 2016 </option>
	<option value='http://www.tcdailyplanet.net/2016/07/'> July 2016 </option>
	<option value='http://www.tcdailyplanet.net/2016/06/'> June 2016 </option>
	<option value='http://www.tcdailyplanet.net/2016/05/'> May 2016 </option>
	<option value='http://www.tcdailyplanet.net/2016/04/'> April 2016 </option>
	<option value='http://www.tcdailyplanet.net/2016/03/'> March 2016 </option>
	<option value='http://www.tcdailyplanet.net/2016/02/'> February 2016 </option>
	<option value='http://www.tcdailyplanet.net/2016/01/'> January 2016 </option>
	<option value='http://www.tcdailyplanet.net/2015/12/'> December 2015 </option>
	<option value='http://www.tcdailyplanet.net/2015/11/'> November 2015 </option>
	<option value='http://www.tcdailyplanet.net/2015/10/'> October 2015 </option>
	<option value='http://www.tcdailyplanet.net/2015/09/'> September 2015 </option>
	<option value='http://www.tcdailyplanet.net/2015/08/'> August 2015 </option>
	<option value='http://www.tcdailyplanet.net/2015/07/'> July 2015 </option>
	<option value='http://www.tcdailyplanet.net/2015/06/'> June 2015 </option>
	<option value='http://www.tcdailyplanet.net/2015/05/'> May 2015 </option>
	<option value='http://www.tcdailyplanet.net/2015/04/'> April 2015 </option>
	<option value='http://www.tcdailyplanet.net/2015/03/'> March 2015 </option>
	<option value='http://www.tcdailyplanet.net/2015/02/'> February 2015 </option>
	<option value='http://www.tcdailyplanet.net/2015/01/'> January 2015 </option>
	<option value='http://www.tcdailyplanet.net/2014/12/'> December 2014 </option>
	<option value='http://www.tcdailyplanet.net/2014/11/'> November 2014 </option>
	<option value='http://www.tcdailyplanet.net/2014/10/'> October 2014 </option>
	<option value='http://www.tcdailyplanet.net/2014/09/'> September 2014 </option>
	<option value='http://www.tcdailyplanet.net/2014/08/'> August 2014 </option>
	<option value='http://www.tcdailyplanet.net/2014/07/'> July 2014 </option>
	<option value='http://www.tcdailyplanet.net/2014/06/'> June 2014 </option>
	<option value='http://www.tcdailyplanet.net/2014/05/'> May 2014 </option>
	<option value='http://www.tcdailyplanet.net/2014/04/'> April 2014 </option>
	<option value='http://www.tcdailyplanet.net/2014/03/'> March 2014 </option>
	<option value='http://www.tcdailyplanet.net/2014/02/'> February 2014 </option>
	<option value='http://www.tcdailyplanet.net/2014/01/'> January 2014 </option>
	<option value='http://www.tcdailyplanet.net/2013/12/'> December 2013 </option>
	<option value='http://www.tcdailyplanet.net/2013/11/'> November 2013 </option>
	<option value='http://www.tcdailyplanet.net/2013/10/'> October 2013 </option>
	<option value='http://www.tcdailyplanet.net/2013/09/'> September 2013 </option>
	<option value='http://www.tcdailyplanet.net/2013/08/'> August 2013 </option>
	<option value='http://www.tcdailyplanet.net/2013/07/'> July 2013 </option>
	<option value='http://www.tcdailyplanet.net/2013/06/'> June 2013 </option>
	<option value='http://www.tcdailyplanet.net/2013/05/'> May 2013 </option>
	<option value='http://www.tcdailyplanet.net/2013/04/'> April 2013 </option>
	<option value='http://www.tcdailyplanet.net/2013/03/'> March 2013 </option>
	<option value='http://www.tcdailyplanet.net/2013/02/'> February 2013 </option>
	<option value='http://www.tcdailyplanet.net/2013/01/'> January 2013 </option>
	<option value='http://www.tcdailyplanet.net/2012/12/'> December 2012 </option>
	<option value='http://www.tcdailyplanet.net/2012/11/'> November 2012 </option>
	<option value='http://www.tcdailyplanet.net/2012/10/'> October 2012 </option>
	<option value='http://www.tcdailyplanet.net/2012/09/'> September 2012 </option>
	<option value='http://www.tcdailyplanet.net/2012/08/'> August 2012 </option>
	<option value='http://www.tcdailyplanet.net/2012/07/'> July 2012 </option>
	<option value='http://www.tcdailyplanet.net/2012/06/'> June 2012 </option>
	<option value='http://www.tcdailyplanet.net/2012/05/'> May 2012 </option>
	<option value='http://www.tcdailyplanet.net/2012/04/'> April 2012 </option>
	<option value='http://www.tcdailyplanet.net/2012/03/'> March 2012 </option>
	<option value='http://www.tcdailyplanet.net/2012/02/'> February 2012 </option>
	<option value='http://www.tcdailyplanet.net/2012/01/'> January 2012 </option>
	<option value='http://www.tcdailyplanet.net/2011/12/'> December 2011 </option>
	<option value='http://www.tcdailyplanet.net/2011/11/'> November 2011 </option>
	<option value='http://www.tcdailyplanet.net/2011/10/'> October 2011 </option>
	<option value='http://www.tcdailyplanet.net/2011/09/'> September 2011 </option>
	<option value='http://www.tcdailyplanet.net/2011/08/'> August 2011 </option>
	<option value='http://www.tcdailyplanet.net/2011/07/'> July 2011 </option>
	<option value='http://www.tcdailyplanet.net/2011/06/'> June 2011 </option>
	<option value='http://www.tcdailyplanet.net/2011/05/'> May 2011 </option>
	<option value='http://www.tcdailyplanet.net/2011/04/'> April 2011 </option>
	<option value='http://www.tcdailyplanet.net/2011/03/'> March 2011 </option>
	<option value='http://www.tcdailyplanet.net/2011/02/'> February 2011 </option>
	<option value='http://www.tcdailyplanet.net/2011/01/'> January 2011 </option>
	<option value='http://www.tcdailyplanet.net/2010/12/'> December 2010 </option>
	<option value='http://www.tcdailyplanet.net/2010/11/'> November 2010 </option>
	<option value='http://www.tcdailyplanet.net/2010/10/'> October 2010 </option>
	<option value='http://www.tcdailyplanet.net/2010/09/'> September 2010 </option>
	<option value='http://www.tcdailyplanet.net/2010/08/'> August 2010 </option>
	<option value='http://www.tcdailyplanet.net/2010/07/'> July 2010 </option>
	<option value='http://www.tcdailyplanet.net/2010/06/'> June 2010 </option>
	<option value='http://www.tcdailyplanet.net/2010/05/'> May 2010 </option>
	<option value='http://www.tcdailyplanet.net/2010/04/'> April 2010 </option>
	<option value='http://www.tcdailyplanet.net/2010/03/'> March 2010 </option>
	<option value='http://www.tcdailyplanet.net/2010/02/'> February 2010 </option>
	<option value='http://www.tcdailyplanet.net/2010/01/'> January 2010 </option>
	<option value='http://www.tcdailyplanet.net/2009/12/'> December 2009 </option>
	<option value='http://www.tcdailyplanet.net/2009/11/'> November 2009 </option>
	<option value='http://www.tcdailyplanet.net/2009/10/'> October 2009 </option>
	<option value='http://www.tcdailyplanet.net/2009/09/'> September 2009 </option>
	<option value='http://www.tcdailyplanet.net/2009/08/'> August 2009 </option>
	<option value='http://www.tcdailyplanet.net/2009/07/'> July 2009 </option>
	<option value='http://www.tcdailyplanet.net/2009/06/'> June 2009 </option>
	<option value='http://www.tcdailyplanet.net/2009/05/'> May 2009 </option>
	<option value='http://www.tcdailyplanet.net/2009/04/'> April 2009 </option>
	<option value='http://www.tcdailyplanet.net/2009/03/'> March 2009 </option>
	<option value='http://www.tcdailyplanet.net/2009/02/'> February 2009 </option>
	<option value='http://www.tcdailyplanet.net/2009/01/'> January 2009 </option>
	<option value='http://www.tcdailyplanet.net/2008/12/'> December 2008 </option>
	<option value='http://www.tcdailyplanet.net/2008/11/'> November 2008 </option>
	<option value='http://www.tcdailyplanet.net/2008/10/'> October 2008 </option>
	<option value='http://www.tcdailyplanet.net/2008/09/'> September 2008 </option>
	<option value='http://www.tcdailyplanet.net/2008/08/'> August 2008 </option>
	<option value='http://www.tcdailyplanet.net/2008/07/'> July 2008 </option>
	<option value='http://www.tcdailyplanet.net/2008/06/'> June 2008 </option>
	<option value='http://www.tcdailyplanet.net/2008/05/'> May 2008 </option>
	<option value='http://www.tcdailyplanet.net/2008/04/'> April 2008 </option>
	<option value='http://www.tcdailyplanet.net/2008/03/'> March 2008 </option>
	<option value='http://www.tcdailyplanet.net/2008/02/'> February 2008 </option>
	<option value='http://www.tcdailyplanet.net/2008/01/'> January 2008 </option>
	<option value='http://www.tcdailyplanet.net/2007/12/'> December 2007 </option>
	<option value='http://www.tcdailyplanet.net/2007/11/'> November 2007 </option>
	<option value='http://www.tcdailyplanet.net/2007/10/'> October 2007 </option>
	<option value='http://www.tcdailyplanet.net/2007/09/'> September 2007 </option>
	<option value='http://www.tcdailyplanet.net/2007/08/'> August 2007 </option>
	<option value='http://www.tcdailyplanet.net/2007/07/'> July 2007 </option>
	<option value='http://www.tcdailyplanet.net/2007/06/'> June 2007 </option>
	<option value='http://www.tcdailyplanet.net/2007/05/'> May 2007 </option>
	<option value='http://www.tcdailyplanet.net/2007/04/'> April 2007 </option>
	<option value='http://www.tcdailyplanet.net/2007/03/'> March 2007 </option>
	<option value='http://www.tcdailyplanet.net/2007/02/'> February 2007 </option>
	<option value='http://www.tcdailyplanet.net/2007/01/'> January 2007 </option>
	<option value='http://www.tcdailyplanet.net/2006/12/'> December 2006 </option>
	<option value='http://www.tcdailyplanet.net/2006/11/'> November 2006 </option>
	<option value='http://www.tcdailyplanet.net/2006/10/'> October 2006 </option>
	<option value='http://www.tcdailyplanet.net/2006/09/'> September 2006 </option>
	<option value='http://www.tcdailyplanet.net/2006/08/'> August 2006 </option>
	<option value='http://www.tcdailyplanet.net/2006/07/'> July 2006 </option>
	<option value='http://www.tcdailyplanet.net/2006/06/'> June 2006 </option>
	<option value='http://www.tcdailyplanet.net/2006/05/'> May 2006 </option>
	<option value='http://www.tcdailyplanet.net/2006/04/'> April 2006 </option>
	<option value='http://www.tcdailyplanet.net/2006/03/'> March 2006 </option>
	<option value='http://www.tcdailyplanet.net/2006/02/'> February 2006 </option>
	<option value='http://www.tcdailyplanet.net/2006/01/'> January 2006 </option>
	<option value='http://www.tcdailyplanet.net/2005/12/'> December 2005 </option>
	<option value='http://www.tcdailyplanet.net/2005/11/'> November 2005 </option>
	<option value='http://www.tcdailyplanet.net/2005/10/'> October 2005 </option>
	<option value='http://www.tcdailyplanet.net/2005/09/'> September 2005 </option>
	<option value='http://www.tcdailyplanet.net/2000/10/'> October 2000 </option>

		</select>
		</div>	</div>

	</div>
<div id="boilerplate">
	<div class="row-fluid clearfix">
		<div class="span9">
			<ul id="footer-social" class="social-icons">
				<li><a href="http://deep-silk.flywheelsites.com/?feed=rss2" title="Link to RSS Feed"><i class="icon-rss"></i></a></li><li><a href="https:/facebook.com/tcdailyplanet" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/tcdailyplanet" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li>			</ul>
		</div>

			</div>

	<div class="row-fluid clearfix">
		<div class="span9">
			<div class="footer-bottom clearfix">

				<!-- If you enjoy this theme and use it on a production site we would appreciate it if you would leave the credit in place. Thanks :) -->
				<p class="footer-credit">&copy; Copyright 2017, Twin Cities Enterprise</p>
				<p class="footer-credit">This site built with <a href="http://largoproject.org">Project Largo</a> from <a href="http://inn.org">INN</a> and proudly powered by <a href="http://wordpress.org" rel="nofollow">WordPress</a>.</p>
			</div>
		</div>
		<div class="span3">
					</div>
	</div>

	<div class="row-fluid clearfix">
		<div class="span12">
			<p class="back-to-top"><a href="#top">Back to top &uarr;</a></p>
					</div>
	</div>
</div>

	</footer>
</div>

<div class="sticky-footer-holder">
	<div class="sticky-footer-container social-icons">

		
						<div class="comments">
			<a href="http://www.tcdailyplanet.net/music-review-sesame-street-live-lets-dance-state-theatre/#comments"><h4>Comment</h4> <i class="icon-comment"></i></a>
		</div>
		
		<div class="dismiss">
			<a href="#">
			<i class="icon-cancel"></i>
			</a>
		</div>

						<div class="follow">
			<h4>Follow</h4>

			<span class="post-category-link"><a href="http://www.tcdailyplanet.net/category/article/" title="Read Posts in the Article category"><i class="icon-white icon-tag"></i>Article</a></span>
																<div class="follow-author">
					<a href="http://www.tcdailyplanet.net/author/gino-terrell/feed/gino-terrell/" class="icon-rss"></a>
											<a href="https://twitter.com/gin026" class="icon-twitter"></a>
										<a href="http://www.tcdailyplanet.net/author/gino-terrell/">Gino Terrell</a>
					</div>
							
		</div>

	</div>
</div>
		<script type="text/javascript">
		/*<![CDATA[*/
		var gmapstyles = 'default';
		/* ]]> */
		</script>		
				<script type="text/javascript">
			var LMP = {"ajax_url":"http:\/\/www.tcdailyplanet.net\/wp-admin\/admin-ajax.php","paged":0,"query":{"post__not_in":null,"page":"","name":"music-review-sesame-street-live-lets-dance-state-theatre"},"is_home":false,"is_series_landing":false};
		</script>
	

		
		<!--Facebook-->
		<div id="fb-root"></div>
		<script>(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));</script>

		
		
		<!--Twitter-->
		<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

		
	<script type='text/javascript' src='http://www.tcdailyplanet.net/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<div class='evo_lightboxes'>					<div class='evo_lightbox eventcard eventon_events_list' id=''>
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose '>X</a>
									<div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'></div>
								</div>
							</div>							
						</div>
					</div>
					</div><link rel='stylesheet' id='yarppRelatedCss-css'  href='http://www.tcdailyplanet.net/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.7.2' type='text/css' media='all' />
<script type='text/javascript' src='http://www.tcdailyplanet.net/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='http://www.tcdailyplanet.net/www/wp-content/themes/tcdailyplanet-largo-child/js/your_theme.js?ver=0.1.0'></script>
<script type='text/javascript' src='http://www.tcdailyplanet.net/wp-content/themes/largo/js/load-more-posts.js'></script>
<script type='text/javascript' src='http://www.tcdailyplanet.net/wp-content/themes/largo/js/largoCore.min.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.tcdailyplanet.net/wp-content/themes/largo/js/largoPlugins.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.tcdailyplanet.net/wp-content/themes/largo/js/jquery.idTabs.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.tcdailyplanet.net/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>

</body>
</html>
